Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 мая 2024, 06:33

Помогите понять как заполнить таблицу

Автор Evgenator8475, 28 апр 2024, 15:22

0 Пользователей и 1 гость просматривают эту тему.

Evgenator8475

&НаСервере
Процедура ПоискНаСервере()
   Перем ЗначениеКафедры, ЗначениеСпециальности, ЗначениеДоступные;
   ЗначениеКафедры = ЭтотОбъект.Кафедра;
   ЗначениеСпециальности = ЭтотОбъект.Специальность;
   


   
   
   
   //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   
   ЗапросВыбора = Новый Запрос;
   ЗапросВыбора.Текст =
      "ВЫБРАТЬ
      |   Профессии.Наименование КАК Наименование,
      |   Профессии.Профессии1.Кафедра КАК Кафедра,
      |      Профессии.Профессии1.Специальность КАК Специальность,
      |      Профессии.Профессии1.Практика КАК Практика,
      |      Профессии.Профессии1.Стажировка КАК Стажировка,
      |      Профессии.Профессии1.Работа КАК Работа
      |   
      |         ИЗ
      |   Справочник.Профессии КАК Профессии
      |ГДЕ
      |   Профессии.Профессии1.Кафедра = &Кафедра
      |   И Профессии.Профессии1.Специальность = &Специальность";
   
   ЗапросВыбора.УстановитьПараметр("Кафедра", ЗначениеКафедры);
   ЗапросВыбора.УстановитьПараметр("Специальность", СтроковоеПредставлениеСпециальности);
   
   РезультатЗапросВыбора = ЗапросВыбора.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапросВыбора.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Сообщить ("ЗначениеКафедры:" + ЗначениеКафедры);
      Сообщить ("ЗначениеСпециальности:" + ЗначениеСпециальности);
      Сообщить ("ЗначениеДоступные:" + ЗначениеДоступные);
НоваяСтрока = Объект.ПараметрыПоиска.Добавить();
            НоваяСтрока.НаименованиеОрганизации = ВыборкаДетальныеЗаписи.Наименование;
            НоваяСтрока.Должность = ВыборкаДетальныеЗаписи.Работа;
            НоваяСтрока.Практика = ВыборкаДетальныеЗаписи.Практика;
            НоваяСтрока.Стажировка = ВыборкаДетальныеЗаписи.Стажировка;
   КонецЦикла;
КонецПроцедуры

Подскажите как мне поправить код чтобы у меня все заполнялось корректно.
У меня просто заполняется наименование организации и все все остальное пусто

Evgenator8475

Процедура ПоискНаСервере()
   Перем ЗначениеКафедры, ЗначениеСпециальности, ЗначениеДоступные;
   ЗначениеКафедры = ЭтотОбъект.Кафедра;
   ЗначениеСпециальности = ЭтотОбъект.Специальность;
   ЗапросВыбора = Новый Запрос;
   ЗапросВыбора.Текст =
      "ВЫБРАТЬ
      |   Профессии.Наименование КАК Наименование,
      |   Профессии.Профессии1.Кафедра КАК Кафедра,
      |      Профессии.Профессии1.Специальность КАК Специальность,
      |      Профессии.Профессии1.Практика КАК Практика,
      |      Профессии.Профессии1.Стажировка КАК Стажировка,
      |      Профессии.Профессии1.Работа КАК Работа
      |   
      |         ИЗ
      |   Справочник.Профессии КАК Профессии
      |ГДЕ
      |   Профессии.Профессии1.Кафедра = &Кафедра
      |   И Профессии.Профессии1.Специальность = &Специальность";
   
   ЗапросВыбора.УстановитьПараметр("Кафедра", ЗначениеКафедры);
   ЗапросВыбора.УстановитьПараметр("Специальность", ЭтотОбъект.Специальность);
   
   РезультатЗапросВыбора = ЗапросВыбора.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапросВыбора.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Сообщить ("ЗначениеКафедры:" + ЗначениеКафедры);
      Сообщить ("ЗначениеСпециальности:" + ЗначениеСпециальности);
      Сообщить ("ЗначениеДоступные:" + ЗначениеДоступные);
            НоваяСтрока = Объект.ПараметрыПоиска.Добавить();
            НоваяСтрока.НаименованиеОрганизации = ВыборкаДетальныеЗаписи.Наименование;
            НоваяСтрока.Должность = ВыборкаДетальныеЗаписи.Работа;
            НоваяСтрока.Практика = ВыборкаДетальныеЗаписи.Практика;
            НоваяСтрока.Стажировка = ВыборкаДетальныеЗаписи.Стажировка;
   КонецЦикла;
КонецПроцедуры
немного исправленный код

Evgenator8475


Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск