Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 июн 2024, 01:52

Создание вариантов отчета для внешнего отчета, когда они не используются

Автор Shoroh6400, 15 апр 2024, 09:47

0 Пользователей и 1 гость просматривают эту тему.

Shoroh6400

Добрый день. Версия платформы 8.3.21
Столкнулась с такой задачей: в ЗУП 3.1.28 необходимо добавить отчет и сделать так, чтобы он отражался во вкладке "Все кадровые отчеты".
Нашла решение, что для этого необходимо создать вариант отчета и включить его в эту вкладку. Но при подключении внешнего отчета нет вкладки "Варианты отчета" -> "Размещение".
Хранилище вариантов отчета в свойствах заполнено. Отчет написан без использования СКД. Как таковых вариантов у него и нет.
Подскажите, можно ли создать какую-то программную заглушку, чтобы эта вкладка появилась? И куда ее добавить?

Shoroh6400

Нашла вот такое решение. В форму добавила вот такой код

&НаКлиенте
Процедура ПриЗакрытии(ЗавершениеРаботы)
СохранитьТекущиеНастройкиВариантаОтчета();
    // Чтобы не спрашивал сохранение варианта   
    ВариантМодифицирован = Ложь;
КонецПроцедуры

&НаСервере
Процедура СохранитьТекущиеНастройкиВариантаОтчета()
   
    ИмяОтчетаВнешний         = "ВнешнийОтчет.УведомлениеОЗаключенииТрудовогоДоговораСИностраннымГражданиномОтчет";
    ИмяОтчетаТек             = "";

КлючТекущегоВарианта = ХранилищеСистемныхНастроек.Загрузить(ИмяОтчетаВнешний + "/КлючТекущегоВарианта");
    ИмяОтчетаТек = ИмяОтчетаВнешний;           
   
    Если КлючТекущегоВарианта = Неопределено Тогда
        Возврат;
    КонецЕсли;   
   
    ОписаниеВарианта     = ХранилищеВариантовОтчетов.ПолучитьОписание(ИмяОтчетаТек, КлючТекущегоВарианта);
    ВариантОтчета         = Отчет.КомпоновщикНастроек.Настройки;
   
    ХранилищеВариантовОтчетов.Сохранить(ИмяОтчетаТек, КлючТекущегоВарианта, ВариантОтчета, ОписаниеВарианта);   
   
КонецПроцедуры

В результате при добавлении и первой отработке отчета сохраняется "стандартный вариант", потом уже можно без проблем добавить его в интефейс

Похожие темы (5)

Рейтинг@Mail.ru

Поиск