Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 мая 2024, 06:11

Telegram bot и 1С

Автор Karatel, 05 апр 2024, 10:02

0 Пользователей и 1 гость просматривают эту тему.

Karatel

Всем привет, кто работал с телеграмм ботом? Мне необходимо, файл отправлять в 1С, в нужный справочник, находить по id элементу или номеру товара и прикреплять в прикрепленные файлы, данный полученный файл с телеграмм бота. Тексты всё прекрасно отрабатывает, по id привязка идёт и к нему же обращается в боте. А файл не понятно как привязать. То есть смысл такой, пользователю в бот приходит сообщение, что необходимо отработать заявку, он приступает, отрабатывает текстовые информации и т.д., потом приходит сообщение что необходимо прикрепить файл, он вставляет его, но как сделать так чтобы он именно определял к какому элементу в справочнике прикрепить его.
Если НЕ message["photo"] = Неопределено Тогда
file_id = Неопределено;
last_file_size = 0;

Для Каждого photo из message["photo"] Цикл
file_size = photo["file_size"];
Если file_size > last_file_size Тогда
last_file_size = file_size;
file_id = photo["file_id"];
КонецЕсли;
КонецЦикла;

Если НЕ file_id = Неопределено Тогда
result = tl_Методы.getFile(file_id);
Если result["result"] = Неопределено Тогда
Возврат Ответ;
КонецЕсли;

ДанныеФайла = result["result"];
file_path = ДанныеФайла["file_path"];
КонецЕсли;
Вот так я получаю файл, далее нужно вставить именно в тот элемент справочника по которому идёт отработка заявки

prosoft1

через вебхуки

Karatel

prosoft1, Так и делаю

antoneus

А откуда приходит сообщение, что необходимо прикрепить файл?

Похожие темы (4)

Рейтинг@Mail.ru

Поиск