Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 мая 2024, 07:06

Параметр с указанным именем не найден

Автор FantomASS, 04 апр 2024, 13:31

0 Пользователей и 1 гость просматривают эту тему.

FantomASS

Всем добрый день, я хочу в динамическом списке сделать автоматическую фильтрацию по клиенту В ЗадачеЦРМ клиента брать из реквизита "Лид"

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Параметры.Свойство("Основание", Основание);
Сообщить(Основание.Наименование);
ОснованиеТип = ТипЗнч(Основание);

Если ОснованиеТип = Тип("ЗадачаСсылка.ЗадачаБП") Тогда
КлиентЛид = Основание.Клиент;
ИначеЕсли ОснованиеТип = Тип("ЗадачаСсылка.ЗадачаЦРМ") Тогда
КлиентЛид = Основание.Лид;
Иначе
КлиентЛид = Основание;
КонецЕсли;

КлиентЛидТип = ТипЗнч(КлиентЛид);

Если КлиентЛидТип = Тип("СправочникСсылка.Клиенты") Тогда
АдреснаяКнигаСписок.Параметры.УстановитьЗначениеПараметра("Клиент", КлиентЛид);
ИначеЕсли КлиентЛидТип = Тип("СправочникСсылка.Лиды") Тогда
АдреснаяКнигаСписок.Параметры.УстановитьЗначениеПараметра("Клиент", КлиентЛид);
Иначе
Отказ = Истина;
Сообщить("Неверный тип основания");
КонецЕсли;
КонецПроцедуры;

Но программа выдает ошибку

Ошибка при вызове метода контекста (УстановитьЗначениеПараметра)
{ОбщаяФорма.АдреснаяКнига.Форма(21)}:АдреснаяКнигаСписок.Параметры.УстановитьЗначениеПараметра("Клиент", КлиентЛид);
{ОбщаяКоманда.АдреснаяКнига.МодульКоманды(4)}:ОткрытьФорму("ОбщаяФорма.АдреснаяКнига",

по причине:
Параметр с указанным именем не найден


Как можно исправить?


antoneus

Это надо не через параметры делать, а через отбор.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск