Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 мая 2024, 06:34

сохранение файла во временную таблицу

Автор Nosferatu112, 29 мар 2024, 16:03

0 Пользователей и 1 гость просматривают эту тему.

Nosferatu112

Всем привет, я достаю файлы HttP запросом
&НаКлиенте
Процедура НайтиФайлыЗвонков(Команда)
НайтиФайлыНаСервере();
Для Каждого С Из ТЧсСсылками Цикл

ПутьДляСохранения = С.Каталог;
Ответ = РаботаСИнтернетКлиентСервер.ЗапросHTTP(С.СсылкаНаФайл,,,,,ПутьДляСохранения);
Если Ответ.КодСостояния = 200 Тогда                           
Данные = ДляРС.Добавить();
Данные.ИмяФайла = С.ИмяФайла;
Данные.Дата = С.Дата;
УстановкаБулево();
КонецЕсли;
КонецЦикла;


КонецПроцедуры
&НаСервере
Процедура УстановкаБулево()
Для Каждого С Из ДляРС Цикл
Запись = РегистрыСведений.ЖурналЗвонков.СоздатьМенеджерЗаписи();
Запись.Дата = С.Дата;
Запись.Файл = С.ИмяФайла;
Запись.Прочитать();
Если Запись.Выбран() Тогда
Запись.ФайлОтпраленДляТранскрибации = Истина;
Запись.Записать();
КонецЕсли;
ДляРС.Очистить();
КонецЦикла;

КонецПроцедуры
Как правильно в этой строке Ответ = РаботаСИнтернетКлиентСервер.ЗапросHTTP(С.СсылкаНаФайл,,,,,ПутьДляСохранения); указать вместо папки на компе ВТшку что бы дальше перекинуть файлы на другой сервер без надобности создания папки

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск