Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 мая 2024, 03:07

Перебор столбца в табличной части в обработке

Автор FantomASS, 15 мар 2024, 12:17

0 Пользователей и 1 гость просматривают эту тему.

FantomASS

У меня имеется табличная часть с расположениями конфигураций. Как можно реализовать перебор каждого расположения для обновления расширения через модуль

&НаКлиенте
Процедура ЗаписатьДанные(Команда)
Сообщить(ПутьКФайлу);
Команда = """C:\Program Files\1cv8\common\1cestart.exe"" DESIGNER /F """+Расположение+""" /N """+Логин+""" /P """+Пароль+""" /LoadCfg """+ПутьКФайлу+""" -Extension Расширение1 /UpdateDBCfg""";
ЗапуститьПриложение(Команда);
КонецПроцедуры

&НаСервере
Процедура ПрочитатьФайл_XLSX_НаСервере()

ТабДок = Новый ТабличныйДокумент;
Попытка

ТабДок.Прочитать(ЭтотОбъект.ПутьКФайлу, СпособЧтенияЗначенийТабличногоДокумента.Значение);

Исключение
Сообщение = Новый СообщениеПользователю;
Сообщение.Текст = "Не удалось прочитать указанный файл по причине: " + ОписаниеОшибки();
Сообщение.Сообщить();
Возврат;

КонецПопытки;

КоличествоСтрок = ТабДок.ВысотаТаблицы;

Для НомерСтроки = 2 По КоличествоСтрок  Цикл
СтрокаДанных = Объект.ТабличнаяЧасть1.Добавить();
СтрокаДанных.Наименование = ТабДок.ПолучитьОбласть("R" + Формат(НомерСтроки, "ЧГ=0") + "C" + 1).ТекущаяОбласть.Текст;
СтрокаДанных.УНП = ТабДок.ПолучитьОбласть("R" + Формат(НомерСтроки, "ЧГ=0") + "C" + 2).ТекущаяОбласть.Текст;
СтрокаДанных.Расположение = ТабДок.ПолучитьОбласть("R" + Формат(НомерСтроки, "ЧГ=0") + "C" + 3).ТекущаяОбласть.Текст;



КонецЦикла;

КонецПроцедуры // ПрочитатьФайл_XLSX_НаСервере()

&НаКлиенте
Процедура ПрочитатьФайл_XLSX()
ПрочитатьФайл_XLSX_НаСервере();

КонецПроцедуры // ПрочитатьФайл_XLSX()

FantomASS


Максим75

FantomASS, Так прямо в цикле табличную часть обойти и передать вместо ПутьКФайлу путь из Расположение.

п.с. а загрузка из Ексель к чему?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск