Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 июн 2024, 01:39

Как передать значение переменной из одной процедуры в другую

Автор FantomASS, 15 мар 2024, 09:32

0 Пользователей и 1 гость просматривают эту тему.

FantomASS

Как передать значение переменной Файл из процедуры ПослеВыбораФайла в ЗаписатьДанные
&НаКлиенте
Процедура ПослеВыбораФайла(ВыбранныеФайлы, ДополнительныеПараметры) Экспорт
Если ВыбранныеФайлы = Неопределено Тогда
Возврат;
КонецЕсли;

ЭтотОбъект.ПутьКФайлу = ВыбранныеФайлы[0];
Файл = ЭтотОбъект.ПутьКФайлу;
Сообщить(Файл);



КонецПроцедуры // ПослеВыбораФайла()

&НаКлиенте
Процедура ЗаписатьДанные(Команда, Файл)
Сообщить(Файл);

Команда = """C:\Program Files\1cv8\common\1cestart.exe"" DESIGNER /F ""C:\Users\1c1\Documents\InfoBase1"" /N ""Администратор"" /P """" /LoadCfg """+Файл+""" -Extension Расширение1 /UpdateDBCfg""";
ЗапуститьПриложение(Команда);
КонецПроцедуры

Максим75

FantomASS, так если у Вас уже есть реквизит у объекта под названием ПутьКФайлу, вот его и используйте.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск