Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 мая 2024, 07:29

Фильтрация всех реквизитов форм

Автор trammr, 04 мар 2024, 12:14

0 Пользователей и 1 гость просматривают эту тему.

trammr

Есть ли возможность создать в общей форме выбор значения по которому отфильтруются все значения других форм справочников по определенному реквизиту?

antoneus

Ниче не понял) Но на всякий случай: да, такая возможность есть.

LexaK

Цитата: trammr от 04 мар 2024, 12:14в общей форме выбор значения по которому отфильтруются все значения других форм справочников
да, есть такая общая форма, называется Консоль запросов!
в ней можно отфильтровать по любым реквизитам и получить любые данные по любым объектам.
если помогло нажмите: Спасибо!

trammr

LexaK, я так понял вы имеете ввиду запросы по типу sql, но можно ли заранее выставлять фильтр всем справочникам по заданным значениям в общей форме и после выставленных значений смотреть отфильтрованные справочники?

LexaK

trammr, вообще, то что вы спрашиваете, очень похоже на РЛС,
где каждый пользователь видит только те данные которые настроены в соответствии с его ролями и настройками.

почитайте, все что найдете по РЛС.
если помогло нажмите: Спасибо!

shamsbjj

Процедура ФильтрацияРеквизитовФормы(Форма)
    // Проходим по всем реквизитам формы
    Для каждого Реквизит Из Форма.Реквизиты Цикл
        Если Условие(Реквизит) Тогда
            // Действия по фильтрации реквизита
            Реквизит.ПометкаУдаления = Истина;
        КонецЕсли;
    КонецЦикла;
   
    // Удаляем помеченные реквизиты
    Форма.УдалитьРеквизиты();
КонецПроцедуры

antoneus

shamsbjj, круто) И что, код работает?

shamsbjj


Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск