Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 мая 2024, 03:57

Помогите разобраться пожалуйста

Автор WartDeid, 01 мар 2024, 12:42

0 Пользователей и 1 гость просматривают эту тему.

WartDeid


&НаКлиенте
Процедура ТоварыЦенаПриИзменении(Элемент)
   Стр = Элементы.Товары.ТекущиеДанные;
   Стр.Сумма = Стр.Количество * Стр.Цена;
   Объект.СуммаПоДокументу = Объект.Товары.Итог("Сумма") + Объект.Услуги.Итог("Сумма");
КонецПроцедуры

&НаКлиенте
Процедура УслугиЦенаПриИзменении(Элемент)
   Стр = Элементы.Услуги.ТекущиеДанные;
   Стр.Сумма = Стр.Количество * Стр.Цена;
   Объект.СуммаПоДокументу = Объект.Товары.Итог("Сумма") + Объект.Услуги.Итог("Сумма");
КонецПроцедуры

&НаКлиенте
Процедура УслугиКоличествоПриИзменении(Элемент)
   Стр = Элементы.Услуги.ТекущиеДанные;
   Стр.Сумма = Стр.Количество * Стр.Цена;
   Объект.СуммаПоДокументу = Объект.Товары.Итог("Сумма") + Объект.Услуги.Итог("Сумма");
КонецПроцедуры

Процедура ТоварыКоличествоПриИзменении(Элемент)
   Стр = Элементы.Товары.ТекущиеДанны;
   Стр.Сумма = Стр.Количество * Стр.Цена;
   Объект.СуммаПоДокументу = Объект.Товары.Итог("Сумма") + Объект.Услуги.Итог("Сумма");
КонецПроцедуры


вот мои процедуры, но суммы не считаются, может кто подсказать, впервые столкнулся с 1c.
прикрепил базу на всякий случай

LexaK

WartDeid, а вы эти процедуры назначили в виде обработчиков соответствующих полей?
в конфигураторе, с свойствах поля, События...

при отладке программа заходит в ваши процедуры? поставьте точку остановки
если помогло нажмите: Спасибо!

WartDeid

LexaK, в графе ПриИзменении я указал эти процедуры для каждого поля. Если я правильно вас понял

WartDeid

LexaK, поставил точку остановки в процедурах, но ничего не изменилось, он получается их не видит?

antoneus

Форма у документа поступления не установлена, поэтому при добавлении документа появляется форма, автоматически сгенерированная, а не ваша.

WartDeid


Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск