Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 мая 2024, 03:49

Ошибка переменной

Автор OlgaTu, 26 фев 2024, 09:47

0 Пользователей и 1 гость просматривают эту тему.

OlgaTu

Помогите, Подскажите, пожалуйста... где я не вижу ошибку....

на форме

 
&НаКлиенте
Процедура yu_yu_ПодборРолейПосле()
     
   
           ОткрытьФорму("Обработка.yu_ПодборРолейЛогос.Форма",,ЭтаФорма,,,,, РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);     
                   
   
КонецПроцедуры         

   &НаКлиенте
Процедура yu_ОбработкаОповещения(ИмяВызова, Параметр, Источник)
    АдресВХ = Параметр;
    Если ИмяВызова = "ЗаполнитьПоПодбору" Тогда
        Объект.yu_РолиLogos.Очистить();
        ЗаполнитьПоПодборуНаСервере(АдресВХ);
    КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьПоПодборуНаСервере(АдресВХ)
    РолиТаблицаЗначений = ПолучитьИзВременногоХранилища(АдресВХ);
    Объект.yu_РолиLogos.Загрузить(РолиТаблицаЗначений);
КонецПроцедуры




Далее сделала обработку и в ней прописала

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Запрос = Новый Запрос(
    "ВЫБРАТЬ
    |    Объект.ТабличнаяЧасть1.РолиТаблицаЗначений.НазваниеРоли.Ссылка КАК Роль,
    |    ЛОЖЬ КАК Флаг
    |ИЗ
    |    Справочник.yu_РолиLogos КАК Роль");
    РольТаблицаЗначений.Загрузить(Запрос.Выполнить().Выгрузить());
КонецПроцедуры

&НаКлиенте
Процедура Перенести(Команда)
    АдресВХ = ПеренестиСервере();
    Оповестить("ЗаполнитьПоПодбору", АдресВХ);
    ЭтаФорма.Закрыть();
КонецПроцедуры

Функция ПеренестиСервере()
    УдалитьСтроки = РольТаблицаЗначений.НайтиСтроки(Новый Структура("Флаг", Ложь));
    Для каждого Строка Из УдалитьСтроки Цикл
        РольТаблицаЗначений.Удалить(Строка);
    КонецЦикла;
    Возврат ПоместитьВоВременноеХранилище(РольТаблицаЗначений.Выгрузить());
КонецФункции


и в итоге выдает ошибку, что не видит переменную.....РольТаблицаЗначений


Что не так написано (((((

antoneus

Ну значит нет такого реквизита формы.

fruitella

Ну наверно потому что ты назвал ее не РольТаблицаЗначений а РолиТаблицаЗначений

&НаСервере
Процедура ЗаполнитьПоПодборуНаСервере(АдресВХ)
   РолиТаблицаЗначений = ПолучитьИзВременногоХранилища(АдресВХ);
   Объект.yu_РолиLogos.Загрузить(РолиТаблицаЗначений);
КонецПроцедуры

Но это тупо переменная, врятли она где-то влияет. Но думаю все же где-то допустил синтаксическую ошибку в наименовании.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск