Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 мая 2024, 02:17

Запрет распроведения и пометки удаления

Автор Nosferatu112, 22 фев 2024, 17:04

0 Пользователей и 1 гость просматривают эту тему.

Nosferatu112

Всем доброго времени суток, такой вопрос есть у меня кусок кода который даёт форме только просмотр истина при определённых условиях
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ГруппыПользователейСостав.Ссылка КАК Ссылка,
| ГруппыПользователейСостав.Пользователь КАК Пользователь
|ИЗ
| Справочник.ГруппыПользователей.Состав КАК ГруппыПользователейСостав
|ГДЕ
| ГруппыПользователейСостав.Ссылка = &Ссылка
| И НЕ ГруппыПользователейСостав.Пользователь.ПометкаУдаления";

Запрос.УстановитьПараметр("Ссылка", Справочники.ГруппыПользователей.НайтиПоНаименованию("Бухгалтерия"));

РезультатЗапроса = Запрос.Выполнить();

Выб = РезультатЗапроса.Выбрать();

Пока Выб.Следующий() Цикл
Если Выб.Пользователь = Пользователи.ТекущийПользователь() Тогда
ЭтаФорма.ТолькоПросмотр = Ложь;
Прервать;
КонецЕсли;
Если Выб.Пользователь <> Пользователи.ТекущийПользователь() И Объект.Проведен = Истина Тогда
ЭтаФорма.ТолькоПросмотр = Истина;
КонецЕсли;

КонецЦикла;
Как реализовать такую проверку для запрета отмены проведения и пометки удаления если пользователя нет в группе, в какой процедуре отслидить что док пытаються распрвести

Afinogen

 B) может проще разорбраться с правами доступа?

Nosferatu112

Afinogen, В этой базе все права доступа через группы пользователей поэтому и задача так стоит, так что не вариант

Afinogen

 B) они везде так, это типовой механизм : профили групп доступа и т.д.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск