Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 мая 2024, 04:05

открытие формы и передача множественного выбора

Автор OlgaTu, 19 фев 2024, 19:27

0 Пользователей и 1 гость просматривают эту тему.

OlgaTu

Привет!

Помогите, плз, что-то сложно мне даются азы... :xfbnsdfb:  :xfbnsdfb:  :xfbnsdfb:  :xfbnsdfb:  :dfbsdfbsdf:  :dfbsdfbsdf:  :dfbsdfbsdf:
Есть справочник ролей для к/аг (клиент, поставщик и пр - около 30 гтук)

Есть справочник партнера

На форме партнера сделала кнопку, по которой должна вызавать отдельная форма из справочника ролей - должна быть возможность множественного выбора (2 и более роли) - и далее эти данные записать в табличную часть на форме партнера (табличная часть создана)

Что сделано - формаВыбора в справочнике Ролей создана.

Как написать процедуру, чтобы она вызывалась в формеЭлемента партнера????

Максим75

Цитата: OlgaTu от 19 фев 2024, 19:27Как написать процедуру, чтобы она вызывалась в формеЭлемента партнера????

Пишите процедуру в Модуле менеджера, делаете ее экспортной. И потом вызываете откуда хотите через Справочники.Имя справочника.Имя процедуры

Может конечно не понял задачу((

OlgaTu

Максим75,
а скорее всего - это я не понятно описала(((

я написала вот такое

 
&НаСервере
Процедура yu_yu_ПодборРолейПослеНаСервере()
   // Вставить содержимое обработчика.
   
   СтандартнаяОбработка = Ложь;
    ФормаСписка =  Справочники.yu_РолиЛогоса.ПолучитьФормуСписка(ФормаСписка);
    ФормаСписка.РежимВыбора = Истина;
    ФормаСписка.МножественныйВыбор(Справочники.yu_РолиЛогоса.ПустаяСсылка());
    ФормаСписка.Открыть();
   
КонецПроцедуры

&НаКлиенте
Процедура yu_yu_ПодборРолейПосле(Команда)
   yu_yu_ПодборРолейПослеНаСервере();
КонецПроцедуры


но при нажатии кнопки в предприятии он выдает ошибку:

Ошибка при вызове метода контекста (ПолучитьФормуСписка)
{Yusen Справочник.Партнеры.Форма.ФормаЭлемента.Форма(55)}:ФормаСписка =  Справочники.yu_РолиЛогоса.ПолучитьФормуСписка(ФормаСписка);
{Yusen Справочник.Партнеры.Форма.ФормаЭлемента.Форма(64)}:yu_yu_ПодборРолейПослеНаСервере();

[ОшибкаВоВремяВыполненияВстроенногоЯзыка]
по причине:
Интерактивные операции недоступны
[ОшибкаИспользованияВстроенногоЯзыка]

Максим75

OlgaTu, просто ПолучитьФорму, а там указывается какая форма (списка, выбора или элемента)

Максим75

Максим75, кстати, а зачем так Вы делаете?
я так понимаю, что нужен множественный выбор элементов справочника. так организуйте через список выбора. заполните список чем надо и такую штуку как ОтметитьЭлементы (или его асинхронный аналог ПоказатьОтметкуЭлементов) выберите что надо.

OlgaTu

Максим75, если бы я смогла понять этот вариант ....

в справочнике с ролям - сделала формуВыбора

а потом в справочнике партнеры - пытаюсь вызвать эту форму и сделать множественный выбор....

пока на слове - пытаючь - все и остается

OlgaTu

Максим75,
сделала   :D

ПараметрыФормы = Новый Структура;
   ПараметрыФормы.Вставить("РежимВыбора",Истина);
   ПараметрыФормы.Вставить("МножественныйВыбор",Истина);
   ПараметрыФормы.Вставить("ЗакрыватьПриВыборе",ложь);
   

   ОткрытьФорму("Справочник.МойСправочник.ФормаВыбора",ПараметрыФормы,ЭтаФорма);


Теперь пошла решать следующий вопрос


нужно очистить ТЧ и перенести новые значения :trhregerhg:

Максим75

&НаКлиенте
Процедура ОткрытьФормуВыбораЧегоТо(Команда)

ОбработчикВыбораЧегоТо = Новый ОписаниеОповещения("ОбработкаВыбораЧегоТо", ЭтотОбъект);

ОткрытьФорму("Обработка.Обработка1.Форма.ФормаВыбораЧегоТо",,,,,, ОбработчикВыбораЧегоТо, РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);

КонецПроцедуры


&НаКлиенте
Процедура ОбработкаВыбораЧегоТо(НекоеЗначение, ДополнительныеПараметры) Экспорт

Сообщение = Новый СообщениеПользователю;
Сообщение.Текст = "Вызываемая форма вернула значение: " + НекоеЗначение;
Сообщение.Сообщить();

КонецПроцедуры

это вызываете форму (ну понятно, что меняете на свою)

ну а это в вызываемой форме
&НаКлиенте
Процедура КомандаВыбрать(Команда)
Закрыть(НекоеЗначение);
КонецПроцедуры

т.е. что-то возвращаете. В Вашем случае список ссылок.
ну уже потом обрабатываете в вызывающей форме то, что вернула вызываемая форма.

Это не к реализации, а как организовать принцип.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск