Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 фев 2024, 01:24

Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа. по причине: Ошибка преобразования данных XDTO:

Автор Dm1Tr0N, 24 янв 2024, 17:07

0 Пользователей и 1 гость просматривают эту тему.

Dm1Tr0N

ЦитироватьЗдравствуйте, я являюсь начинающим разработчиком 1С, и в ходе своего обучения столкнулся с проблемой что не могу передать нужные мне данные в функцию, уже перепробовал разные способы решения этой проблемы, но увы так и не пришёл к решению, помогите пожалуйста сделать рабочим этот код, я понимаю что задачка которая передо мной стоит максимально простая, но я пока не могу справится, был бы признателен елибы ещё объяснили как все сделать по уму.
Ниже я предоставил несколько скриншотов для понимания, и конфигурацию.

Код Модуля Отчёты.Подарки.ФормаОтчёта в котором возникли проблемы:
&НаСервере
Функция СформироватьНаСервере(Кошелек, Подарок)    
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| БонусныйКошелек.Ссылка,
| БонусныйКошелек.Дата,
| БонусныйКошелек.СуммаДокумента,
| ВЫБОР
| КОГДА &Подарок = 0
| ТОГДА 0
| ИНАЧЕ ЦЕЛ(БонусныйКошелек.СуммаДокумента / &Подарок)
| КОНЕЦ КАК МаксПодарков
|ИЗ
| Документ.БонусныйКошелек КАК БонусныйКошелек
|ГДЕ
| БонусныйКошелек.Ссылка = &Кошелек";

Запрос.УстановитьПараметр("Кошелек", Кошелек.Кошелек);
Запрос.УстановитьПараметр("Подарок", Подарок);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

МаксПодарков = 0;

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл   
МаксПодарков =+ ВыборкаДетальныеЗаписи.Получить("МаксПодарков");
КонецЦикла; 

Возврат МаксПодарков;

КонецФункции

&НаКлиентеНаСервере
Процедура Софрмировать(Команда, Элемент, Объект)
Кошелек = Элементы.Кошелек;
Подарок = Элементы.Подарок.ТекстРедактирования;     

МаксПодароков = СформироватьНаСервере(Кошелек, Подарок);

Строка = СтрШаблон("Максимальное количество подарков стоимостью %1 балла = %2", Подарок, МаксПодароков);
Сообщить(Строка);

КонецПроцедуры

antoneus


Dm1Tr0N


Теги:  1с код 

Похожие темы (5)

Рейтинг@Mail.ru

Поиск