Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 июн 2024, 18:16

Формирование закупок регламентым заданием

Автор Middle, 16 янв 2024, 15:54

0 Пользователей и 1 гость просматривают эту тему.

Middle

Доброго времени суток.
Помогите поставить процедуру которая на кнопке в регламент.
В регламент поставил, чтобы исключить форму, но не помогает, все равно ошибка - //Ошибка при вызове метода контекста (ПолучитьФорму)
Процедура ФормированиеЗаказовПоставщикам () ЭКСПОРТ

    СформироватьЗаказыПоставщикам(Ложь);

КонецПроцедуры //  ФормированиеЗаказовПоставщикам ()

Процедура СформироватьРасчетыСебестоимости() ЭКСПОРТ

На кнопке:
Процедура СформироватьЗаказыПоставщикам(ФормыОткрывать) ЭКСПОРТ

ДатаПланирования = ТекущаяДата();
НомерДняНеделиПланирования = ДеньНедели(ДатаПланирования);

Если НомерДняНеделиПланирования = 1 Тогда
        УсловиеЗапроса = "
| И ТМС_НастройкиДляПланированияЗакупок.ПонедельникПланирование = Истина";
ИначеЕсли НомерДняНеделиПланирования = 2 Тогда
        УсловиеЗапроса = "
| И ТМС_НастройкиДляПланированияЗакупок.ВторникПланирование = Истина";
ИначеЕсли НомерДняНеделиПланирования = 3 Тогда
        УсловиеЗапроса = "
| И ТМС_НастройкиДляПланированияЗакупок.СредаПланирование = Истина";
ИначеЕсли НомерДняНеделиПланирования = 4 Тогда
        УсловиеЗапроса = "
| И ТМС_НастройкиДляПланированияЗакупок.ЧетвергПланирование = Истина";
ИначеЕсли НомерДняНеделиПланирования = 5 Тогда
        УсловиеЗапроса = "
| И ТМС_НастройкиДляПланированияЗакупок.ПятницаПланирование = Истина";
ИначеЕсли НомерДняНеделиПланирования = 6 Тогда
        УсловиеЗапроса = "
| И ТМС_НастройкиДляПланированияЗакупок.СубботаПланирование = Истина";
Иначе УсловиеЗапроса = "
| И ТМС_НастройкиДляПланированияЗакупок.ВоскресеньеПланирование = Истина";
КонецЕсли;

ТекстЗапроса =
"ВЫБРАТЬ
| ТМС_НастройкиДляПланированияЗакупок.Организация,
| ТМС_НастройкиДляПланированияЗакупок.Контрагент,
| ТМС_НастройкиДляПланированияЗакупок.КонтрагентДляОтбора,
| ТМС_НастройкиДляПланированияЗакупок.ГруппаТоваров,
| ТМС_НастройкиДляПланированияЗакупок.ПланироватьСУчетомОстатков,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляАнализа,
| ТМС_НастройкиДляПланированияЗакупок.ОтборИзПоступленийЗаПериод,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляОтбораИзНакладных,
| ТМС_НастройкиДляПланированияЗакупок.ПонедельникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВторникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СредаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ЧетвергПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ПятницаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СубботаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВоскресеньеПоступление
|ИЗ
| РегистрСведений.ТМС_НастройкиДляПланированияЗакупок КАК ТМС_НастройкиДляПланированияЗакупок
|ГДЕ
| ТМС_НастройкиДляПланированияЗакупок.ПонедельникПоступление = ИСТИНА";
ТекстЗапроса = ТекстЗапроса + УсловиеЗапроса;
ТекстЗапроса = ТекстЗапроса + "
|
|ОБЪЕДИНИТЬ
|
|ВЫБРАТЬ
| ТМС_НастройкиДляПланированияЗакупок.Организация,
| ТМС_НастройкиДляПланированияЗакупок.Контрагент,
| ТМС_НастройкиДляПланированияЗакупок.КонтрагентДляОтбора,
| ТМС_НастройкиДляПланированияЗакупок.ГруппаТоваров,
| ТМС_НастройкиДляПланированияЗакупок.ПланироватьСУчетомОстатков,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляАнализа,
| ТМС_НастройкиДляПланированияЗакупок.ОтборИзПоступленийЗаПериод,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляОтбораИзНакладных,
| ТМС_НастройкиДляПланированияЗакупок.ПонедельникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВторникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СредаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ЧетвергПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ПятницаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СубботаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВоскресеньеПоступление
|ИЗ
| РегистрСведений.ТМС_НастройкиДляПланированияЗакупок КАК ТМС_НастройкиДляПланированияЗакупок
|ГДЕ
| ТМС_НастройкиДляПланированияЗакупок.ВторникПоступление = ИСТИНА";
ТекстЗапроса = ТекстЗапроса + УсловиеЗапроса;
ТекстЗапроса = ТекстЗапроса + "
|
|ОБЪЕДИНИТЬ
|
|ВЫБРАТЬ
| ТМС_НастройкиДляПланированияЗакупок.Организация,
| ТМС_НастройкиДляПланированияЗакупок.Контрагент,
| ТМС_НастройкиДляПланированияЗакупок.КонтрагентДляОтбора,
| ТМС_НастройкиДляПланированияЗакупок.ГруппаТоваров,
| ТМС_НастройкиДляПланированияЗакупок.ПланироватьСУчетомОстатков,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляАнализа,
| ТМС_НастройкиДляПланированияЗакупок.ОтборИзПоступленийЗаПериод,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляОтбораИзНакладных,
| ТМС_НастройкиДляПланированияЗакупок.ПонедельникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВторникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СредаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ЧетвергПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ПятницаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СубботаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВоскресеньеПоступление
|ИЗ
| РегистрСведений.ТМС_НастройкиДляПланированияЗакупок КАК ТМС_НастройкиДляПланированияЗакупок
|ГДЕ
| ТМС_НастройкиДляПланированияЗакупок.СредаПоступление = ИСТИНА";
ТекстЗапроса = ТекстЗапроса + УсловиеЗапроса;
ТекстЗапроса = ТекстЗапроса + "
|
|ОБЪЕДИНИТЬ
|
|ВЫБРАТЬ
| ТМС_НастройкиДляПланированияЗакупок.Организация,
| ТМС_НастройкиДляПланированияЗакупок.Контрагент,
| ТМС_НастройкиДляПланированияЗакупок.КонтрагентДляОтбора,
| ТМС_НастройкиДляПланированияЗакупок.ГруппаТоваров,
| ТМС_НастройкиДляПланированияЗакупок.ПланироватьСУчетомОстатков,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляАнализа,
| ТМС_НастройкиДляПланированияЗакупок.ОтборИзПоступленийЗаПериод,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляОтбораИзНакладных,
| ТМС_НастройкиДляПланированияЗакупок.ПонедельникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВторникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СредаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ЧетвергПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ПятницаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СубботаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВоскресеньеПоступление
|ИЗ
| РегистрСведений.ТМС_НастройкиДляПланированияЗакупок КАК ТМС_НастройкиДляПланированияЗакупок
|ГДЕ
| ТМС_НастройкиДляПланированияЗакупок.ЧетвергПоступление = ИСТИНА";
ТекстЗапроса = ТекстЗапроса + УсловиеЗапроса;
ТекстЗапроса = ТекстЗапроса + "
|
|ОБЪЕДИНИТЬ
|
|ВЫБРАТЬ
| ТМС_НастройкиДляПланированияЗакупок.Организация,
| ТМС_НастройкиДляПланированияЗакупок.Контрагент,
| ТМС_НастройкиДляПланированияЗакупок.КонтрагентДляОтбора,
| ТМС_НастройкиДляПланированияЗакупок.ГруппаТоваров,
| ТМС_НастройкиДляПланированияЗакупок.ПланироватьСУчетомОстатков,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляАнализа,
| ТМС_НастройкиДляПланированияЗакупок.ОтборИзПоступленийЗаПериод,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляОтбораИзНакладных,
| ТМС_НастройкиДляПланированияЗакупок.ПонедельникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВторникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СредаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ЧетвергПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ПятницаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СубботаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВоскресеньеПоступление
|ИЗ
| РегистрСведений.ТМС_НастройкиДляПланированияЗакупок КАК ТМС_НастройкиДляПланированияЗакупок
|ГДЕ
| ТМС_НастройкиДляПланированияЗакупок.ПятницаПоступление = ИСТИНА";
ТекстЗапроса = ТекстЗапроса + УсловиеЗапроса;
ТекстЗапроса = ТекстЗапроса + "
|
|ОБЪЕДИНИТЬ
|
|ВЫБРАТЬ
| ТМС_НастройкиДляПланированияЗакупок.Организация,
| ТМС_НастройкиДляПланированияЗакупок.Контрагент,
| ТМС_НастройкиДляПланированияЗакупок.КонтрагентДляОтбора,
| ТМС_НастройкиДляПланированияЗакупок.ГруппаТоваров,
| ТМС_НастройкиДляПланированияЗакупок.ПланироватьСУчетомОстатков,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляАнализа,
| ТМС_НастройкиДляПланированияЗакупок.ОтборИзПоступленийЗаПериод,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляОтбораИзНакладных,
| ТМС_НастройкиДляПланированияЗакупок.ПонедельникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВторникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СредаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ЧетвергПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ПятницаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СубботаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВоскресеньеПоступление
|ИЗ
| РегистрСведений.ТМС_НастройкиДляПланированияЗакупок КАК ТМС_НастройкиДляПланированияЗакупок
|ГДЕ
| ТМС_НастройкиДляПланированияЗакупок.СубботаПоступление = ИСТИНА";
ТекстЗапроса = ТекстЗапроса + УсловиеЗапроса;
ТекстЗапроса = ТекстЗапроса + "
|
|ОБЪЕДИНИТЬ
|
|ВЫБРАТЬ
| ТМС_НастройкиДляПланированияЗакупок.Организация,
| ТМС_НастройкиДляПланированияЗакупок.Контрагент,
| ТМС_НастройкиДляПланированияЗакупок.КонтрагентДляОтбора,
| ТМС_НастройкиДляПланированияЗакупок.ГруппаТоваров,
| ТМС_НастройкиДляПланированияЗакупок.ПланироватьСУчетомОстатков,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляАнализа,
| ТМС_НастройкиДляПланированияЗакупок.ОтборИзПоступленийЗаПериод,
| ТМС_НастройкиДляПланированияЗакупок.ЧислоДнейДляОтбораИзНакладных,
| ТМС_НастройкиДляПланированияЗакупок.ПонедельникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВторникПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СредаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ЧетвергПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ПятницаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.СубботаПоступление,
| ТМС_НастройкиДляПланированияЗакупок.ВоскресеньеПоступление
|ИЗ
| РегистрСведений.ТМС_НастройкиДляПланированияЗакупок КАК ТМС_НастройкиДляПланированияЗакупок
|ГДЕ
| ТМС_НастройкиДляПланированияЗакупок.ВоскресеньеПоступление = ИСТИНА";
ТекстЗапроса = ТекстЗапроса + УсловиеЗапроса;

Запрос = Новый Запрос;
Запрос.Текст = ТекстЗапроса;

ВыборкаДетальныеЗаписиНастройкиДляПланирования = Запрос.Выполнить().Выбрать();

Пока ВыборкаДетальныеЗаписиНастройкиДляПланирования.Следующий() Цикл

МассивДней = Новый Массив();
МассивДней.Добавить(НомерДняНеделиПланирования);
Если ВыборкаДетальныеЗаписиНастройкиДляПланирования.ПонедельникПоступление И НомерДняНеделиПланирования <> 1 Тогда
МассивДней.Добавить(1);
КонецЕсли;
Если ВыборкаДетальныеЗаписиНастройкиДляПланирования.ВторникПоступление И НомерДняНеделиПланирования <> 2 Тогда
МассивДней.Добавить(2);
КонецЕсли;
Если ВыборкаДетальныеЗаписиНастройкиДляПланирования.СредаПоступление И НомерДняНеделиПланирования <> 3 Тогда
МассивДней.Добавить(3);
КонецЕсли;
Если ВыборкаДетальныеЗаписиНастройкиДляПланирования.ЧетвергПоступление И НомерДняНеделиПланирования <> 4 Тогда
МассивДней.Добавить(4);
КонецЕсли;
Если ВыборкаДетальныеЗаписиНастройкиДляПланирования.ПятницаПоступление И НомерДняНеделиПланирования <> 5 Тогда
МассивДней.Добавить(5);
КонецЕсли;
Если ВыборкаДетальныеЗаписиНастройкиДляПланирования.СубботаПоступление И НомерДняНеделиПланирования <> 6 Тогда
МассивДней.Добавить(6);
КонецЕсли;
Если ВыборкаДетальныеЗаписиНастройкиДляПланирования.ВоскресеньеПоступление И НомерДняНеделиПланирования <> 7 Тогда
МассивДней.Добавить(7);
КонецЕсли;


МассивДней = СортировкаВыбором(МассивДней);

Если НомерДняНеделиПланирования = МассивДней[МассивДней.ВГраница()] Тогда
НомерДняНеделиПоставки = МассивДней[0];
Иначе
НомерДняНеделиПоставки = МассивДней[МассивДней.Найти(НомерДняНеделиПланирования)+1];
КонецЕсли;

Если НомерДняНеделиПланирования <= НомерДняНеделиПоставки Тогда
ДатаПоставки = ДатаПланирования + (НомерДняНеделиПоставки - НомерДняНеделиПланирования)*86400;
Иначе
ДатаПоставки = ДатаПланирования + (7 - НомерДняНеделиПланирования + НомерДняНеделиПоставки)*86400;
КонецЕсли;

МассивДней.Удалить(МассивДней.Найти(НомерДняНеделиПланирования));

КоличествоВМассивеДней = МассивДней.Количество();

Если КоличествоВМассивеДней = 0 ИЛИ КоличествоВМассивеДней = 1 Тогда
ДатаСледующейПоставки = ДатаПоставки + 7 * 86400;
Иначе
Если НомерДняНеделиПоставки = МассивДней[МассивДней.ВГраница()] Тогда
НомерДняНеделиСледующейПоставки = МассивДней[0];
Иначе
НомерДняНеделиСледующейПоставки = МассивДней[МассивДней.Найти(НомерДняНеделиПоставки)+1];
КонецЕсли;
Если НомерДняНеделиПоставки <= НомерДняНеделиСледующейПоставки Тогда
ДатаСледующейПоставки = ДатаПоставки + (НомерДняНеделиСледующейПоставки - НомерДняНеделиПоставки)*86400;
Иначе
ДатаСледующейПоставки = ДатаПоставки + (7 - НомерДняНеделиПоставки + НомерДняНеделиСледующейПоставки)*86400;
КонецЕсли;
КонецЕсли;

Организация = ВыборкаДетальныеЗаписиНастройкиДляПланирования.Организация;
Контрагент = ВыборкаДетальныеЗаписиНастройкиДляПланирования.Контрагент;
КонтрагентДляОтбора = ВыборкаДетальныеЗаписиНастройкиДляПланирования.КонтрагентДляОтбора;
ГруппаТоваров = ВыборкаДетальныеЗаписиНастройкиДляПланирования.ГруппаТоваров;
ПланироватьСУчетомОстатков = ВыборкаДетальныеЗаписиНастройкиДляПланирования.ПланироватьСУчетомОстатков;
ЧислоДнейДляАнализа = ВыборкаДетальныеЗаписиНастройкиДляПланирования.ЧислоДнейДляАнализа;
ОтборИзПоступленийЗаПериод = ВыборкаДетальныеЗаписиНастройкиДляПланирования.ОтборИзПоступленийЗаПериод;
ЧислоДнейДляОтбораИзНакладных = ВыборкаДетальныеЗаписиНастройкиДляПланирования.ЧислоДнейДляОтбораИзНакладных;

СформироватьОтчетПланированияЗакупокСВыбраннымиПараметрами(ДатаПланирования,ДатаПоставки,ДатаСледующейПоставки,Организация,Контрагент,
КонтрагентДляОтбора,ГруппаТоваров,ПланироватьСУчетомОстатков,ЧислоДнейДляАнализа,ОтборИзПоступленийЗаПериод,ЧислоДнейДляОтбораИзНакладных,Истина,ФормыОткрывать)

КонецЦикла;    

КонецПроцедуры // СформироватьЗаказыПоставщикам()

LexaK

Middle, в указанном вами коде не удалось найти место ошибки  :fdbsdfbsd:
если помогло нажмите: Спасибо!

Middle

Цитата: LexaK от 16 янв 2024, 16:15Middle, в указанном вами коде не удалось найти место ошибки  :fdbsdfbsd:
Вот и я думаю, почему не срабатывает регламентное задание  :dfbbdrfb:

LexaK

Middle, а при интерактивном запуске работает?
если помогло нажмите: Спасибо!

Middle

Цитата: LexaK от 16 янв 2024, 16:28Middle, а при интерактивном запуске работает?
А это как?)  :D  не пробовал ни разу))

LexaK

Middle, интерактивно, это значит - вручную

при нажатии на кнопку, у вас вообще программа работает?
если помогло нажмите: Спасибо!

Middle

Цитата: LexaK от 16 янв 2024, 16:42Middle, интерактивно, это значит - вручную

при нажатии на кнопку, у вас вообще программа работает?
Да, работает

LexaK

Цитата: Middle от 16 янв 2024, 16:48Да, работает
тогда вам остается еще раз перепроверить правильность оформления рабочего кода в регламентное задание!
лучше вам использовать какой нибудь пример, как это правильно делается,
наверняка у вас же в базе их полно!
если помогло нажмите: Спасибо!

Afinogen

так а что за форма должна открываться при вызове "ПолучитьФорму"?

Middle

Еще процедура выполняется после первой, видимо на нее ругается про формы:
Процедура СформироватьОтчетПланированияЗакупокСВыбраннымиПараметрами(ДатаПланирования,ДатаПоставки,ДатаСледующейПоставки,Организация,Контрагент,
КонтрагентДляОтбора,ГруппаТоваров,ПланироватьСУчетомОстатков,ЧислоДнейДляАнализа,ОтборИзПоступленийЗаПериод,ЧислоДнейДляОтбораИзНакладных,ДокументФормировать,ФормыОткрывать) ЭКСПОРТ

Об = Отчеты.ТМС_ПланированиеЗакупок.Создать();

Об.ДатаНачПродаж = ДатаПланирования - 86400 * (ЧислоДнейДляАнализа + 1);
Об.ДатаКонПродаж = ДатаПланирования - 86400;

Об.ПорядокОкругления = 1;
Об.ПоВсейНоменклатуре = Истина;
Об.Организация = Организация;
Об.Контрагент = Контрагент;

Об.ДатаНачЗакупок = ДатаПланирования;
Об.ДатаКонЗакупок = ДатаСледующейПоставки - 86400;

Об.ТМС_ДатаПланирования = ДатаПланирования;
Об.ТМС_ДатаПоступления = ДатаПоставки;
Об.ТМС_ГруппаТоваров = ГруппаТоваров;

ФормаОтчетаПланирования = Об.ПолучитьФорму("Форма");

Если ФормыОткрывать Тогда
ФормаОтчетаПланирования.Открыть();
КонецЕсли;

Если ОтборИзПоступленийЗаПериод Тогда
ДатаНачОтбораИзНакладных = ДатаПланирования - 86400 * (ЧислоДнейДляОтбораИзНакладных + 1);
ДатаКонОтбораИзНакладных = ДатаПланирования - 86400;

ФормаОтчетаПланирования.ЭлементыФормы.Отбор.Значение.Склад.Использование = Истина;
ФормаОтчетаПланирования.ЭлементыФормы.Отбор.Значение.Склад.ВидСравнения = ВидСравнения.Равно;
ФормаОтчетаПланирования.ЭлементыФормы.Отбор.Значение.Склад.Значение = Справочники.Склады.НайтиПоКоду("000000001");

ФормаОтчетаПланирования.ЭлементыФормы.Отбор.Значение.Номенклатура.Использование = Истина;
ФормаОтчетаПланирования.ЭлементыФормы.Отбор.Значение.Номенклатура.ВидСравнения = ВидСравнения.ВСписке;
ФормаОтчетаПланирования.ЭлементыФормы.Отбор.Значение.Номенклатура.Значение = ЗагрузкаИзПоступленийПоКонтрагентам(ДатаНачОтбораИзНакладных,ДатаКонОтбораИзНакладных,Контрагент,КонтрагентДляОтбора,ГруппаТоваров);
Иначе
ФормаОтчетаПланирования.ЭлементыФормы.Отбор.Значение.Склад.Использование = Истина;
ФормаОтчетаПланирования.ЭлементыФормы.Отбор.Значение.Склад.ВидСравнения = ВидСравнения.Равно;
ФормаОтчетаПланирования.ЭлементыФормы.Отбор.Значение.Склад.Значение = Справочники.Склады.НайтиПоКоду("000000001");

ФормаОтчетаПланирования.ЭлементыФормы.Отбор.Значение.Номенклатура.Использование = Истина;
ФормаОтчетаПланирования.ЭлементыФормы.Отбор.Значение.Номенклатура.ВидСравнения = ВидСравнения.ВИерархии;
ФормаОтчетаПланирования.ЭлементыФормы.Отбор.Значение.Номенклатура.Значение = ГруппаТоваров;
КонецЕсли;

ФормаОтчетаПланирования.Сформировать();

Если ДокументФормировать Тогда
Если ПланироватьСУчетомОстатков Тогда
ФормаОтчетаПланирования.СформироватьЗаказ(ФормыОткрывать);
Иначе
ФормаОтчетаПланирования.СформироватьЗаказПоПланируемымПродажам(ФормыОткрывать);
КонецЕсли;
КонецЕсли;

КонецПроцедуры // СформироватьОтчетПланированияЗакупокСВыбраннымиПараметрами()

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск