Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 фев 2024, 01:23

Запрос из Регистра сведений

Автор Funt432286, 15 янв 2024, 17:00

0 Пользователей и 1 гость просматривают эту тему.

Funt432286

Всем доброго времени суток!

Получается какой-то финиш! Делаю запрос по измерению, Выборка возвращается пустой: Выборка.Номенклатура - Ошибка чтения значения.

Номенклатура и ЗСН - Измерение

&НаСервереБезКонтекста
Функция ПолучитьЗСНПриемкаГП(ЗСН)

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ПулЗСН.Номенклатура КАК Номенклатура
|ИЗ
| РегистрСведений.ПулЗСН КАК ПулЗСН
|ГДЕ
| ПулЗСН.ЗСН = &ЗСН";

Запрос.УстановитьПараметр("ЗСН", ЗСН);

РезультатЗапроса = Запрос.Выполнить();

Выборка = РезультатЗапроса.Выбрать();

Ссылка = Выборка.Номенклатура;

Возврат Ссылка;

КонецФункции

&НаКлиенте
Процедура ПриемкаЗСНОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)

Сообщить("Окончание Ввода - " + Текст);

Серийник = ПолучитьЗСНПриемкаГП(Текст);

ТабНом = ТаблПриемки.Добавить();
ТабНом.Номенкл = Серийник;
ТабНом.ЗСН = Текст;
ТабНом.КолПриход = 1;


КонецПроцедуры


Может кто подскажет в чем прикол!

LexaK

Funt432286, надо так
   
    Выборка = РезультатЗапроса.Выбрать();
Если Выборка.Следующий() Тогда
    //только одно значение получите, а если их несколько?
    Ссылка = Выборка.Номенклатура;
Иначе
    Ссылка = Неопределено;
КонецЕсли;
   
    Возврат Ссылка;
 
если помогло нажмите: Спасибо!

Funt432286

LexaK, все равно не получается. Выборка приходит пустая

LexaK

Funt432286, да, иногда бывают такие ошибки.
запускайте тестирование и исправление

в консоли запросов пробовали, чтение данных этого регистра?
или форма списка этого регистра открывается? именно с вашим отбором?
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск