Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2024, 06:32

ЗаписьДокумента по условию Родителя НМК

Автор Vasylii, 27 дек 2023, 18:02

0 Пользователей и 1 гость просматривают эту тему.

Vasylii

есть код в котором я получаю остатки, в этих остатках есть нмк к которым присвоены родители, не могу понять как сделать что бы записывало документ только с заполненым родителем и при условии что бы в документ попадали нмк с одним родителем
Наименованиегрупп = "";

ТаблицаОстатков.Сортировать("Родитель Убыв");
ТаблицаВДок = ТаблицаОстатков.Скопировать();
ТаблицаВДок.Очистить();

Для каждого записи Из ТаблицаОстатков Цикл

Наименованиегрупп = записи.Родитель.Наименование;

Если Наименованиегрупп = записи.Родитель.Наименование тогда
СтрокаТаблица = ТаблицаВДок.Добавить();
ЗаполнитьЗначенияСвойств(СтрокаТаблица,записи);
Иначе
СоздатьДокументПоступленияПоГруппам(Наименованиегрупп,ТаблицаВДок,РеквизитыШапки, ДатаЗагрузки, ПредставлениеТП);
КонецЕсли;

КонецЦикла;

alexandr_ll

Ваш код не работает? Какая ошибка? Что такое НМК и кто такие родители? Как получена таблица остатков?

LexaK

Vasylii, по анализу вашего кода, приходит на ум такой алгоритм
//получаем копию таблицу с колонкой Родитель
ТаблицаРодителей = ТаблицаОстатков.Скопировать(,"Родитель");
//сворачиваем по Родитель, получаем уникальные значения
ТаблицаРодителей.Свернуть("Родитель");

Для каждого лкСтр Из ТаблицаРодителей Цикл
//для каждого значения Родитель, создаем свой документ
СоздатьДокументПоступленияПоГруппам(лкСтр.Родитель, ТаблицаОстатков);
КонецЦикла;

вам остается только немного подправить свою процедуру
СоздатьДокументПоступленияПоГруппам
если помогло нажмите: Спасибо!

Похожие темы (5)

Рейтинг@Mail.ru

Поиск