Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 фев 2024, 08:42

1C 8 розница 2.14 ФИО

Автор vvs_1979, 10 дек 2023, 14:04

0 Пользователей и 1 гость просматривают эту тему.

vvs_1979

Как читать и изменять ФИО Физического лица в справочнике физических лиц забитое в учётной информации ? В реквизитах этого нет (только название, а оно может быть каким угодно).

antoneus

ФИО хранятся не в справочнике, а в регистре сведений ФИОФизическихЛиц, соответственно, читать и изменять надо там.

vvs_1979

И как перебирать полученный регистр.

Выборка =   РегистрыСведений.ФИОФизЛиц;     
Выборка.Выбрать();


Для Каждого Запись Из Выборка Цикл
КонецЦикла
Вызывает ошибку "Итератор для значения неопределён".
а
Пока Выборка.Следующий() Цикл                   
КонецЦикла;
"
Метод объекта не обнаружен: следующий"


vvs_1979


LexaK

vvs_1979, "Без СКЛ" в 1С язык запросов не зависит от наличия СКЛ

вот пример выборки без СКЛ
лкВыборка = РегистрыСведений.ЦеныНоменклатуры.Выбрать();
Пока лкВыборка.Следующий() Цикл

КонецЦикла;
если помогло нажмите: Спасибо!

antoneus

Набор = РегистрыСведений.ФИОФизическихЛиц.СоздатьНаборЗаписей();
Набор.Отбор.ФизическоеЛицо.Установить(СсылкаНаФизЛицо);
Набор.Прочитать();
Для каждого Запись из Набор Цикл
.....

vvs_1979

Цитата: antoneus от 11 дек 2023, 17:10Набор.Отбор.ФизическоеЛицо.Установить(СсылкаНаФизЛицо);
Ошибка: Переменная не определена (СсылкаНаФизЛицо)
Набор.Отбор.ФизЛиц.Установить(<<?>>СсылкаНаФизЛицо); (Проверка: Сервер)

Откуда ссылка ?
Или её надо объявить.

antoneus


vvs_1979

Всё равно не пойму, как ?
Написал:
Набор = РегистрыСведений.ФИОФизЛиц.СоздатьНаборЗаписей();     
СсылкаНаФизЛицо= новый Справочники.ФизическиеЛица.ПустаяСсылка();
Набор.Отбор.ФизЛиц.Установить(СсылкаНаФизЛицо);
Набор.Прочитать();
Для каждого Запись из Набор Цикл     
КонецЦикла;
говорит: Тип не определен (Справочники.ФизическиеЛица.ПустаяСсылка)
Извиняюсь за глупые вопросы :-)

antoneus

Не надо в отбор подставлять пустую ссылку, тем более, что для ее получения оператор "Новый" не нужен.
Зайдем немного с другой стороны. Какая стоит задача и чем не устраивает штатный механизм изменения ФИО?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск