Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 фев 2024, 10:18

Сложить числа при изминении Реквизита

Автор Nosferatu112, 07 дек 2023, 15:45

0 Пользователей и 1 гость просматривают эту тему.

Nosferatu112

Всем доброго времени суток!
Такой вопрос:
Есть ТЗ в ней колонки ИтогоКНачислению и НачислениеДЗ
Как правильно сделать так что бы ПриИзмененииНачислениеДЗ число из этой колонки прибавлялось к колонке ИтогоКНачислению
&НаКлиенте
Процедура ЗаработнаяПлатаНачислениеДЗПриИзменении(Элемент)

Для Каждого С Из Объект.ЗаработнаяПлата Цикл

С.ИтогоКВыплате = С.НачислениеДЗ + С.ИтогоКВыплате;

КонецЦикла;

КонецПроцедуры

LexaK

Nosferatu112, немного не так,
не надо к Итого прибавлять что-то что бы получить сам Итого, нужно вложить все остальные колонки с суммами в строке
примерно так
&НаКлиенте
Процедура ЗаработнаяПлатаНачислениеДЗПриИзменении(Элемент)
   
// ццикл не нужен    Для Каждого С Из Объект.ЗаработнаяПлата Цикл
//        С.ИтогоКВыплате = С.НачислениеДЗ + С.ИтогоКВыплате;
//    КонецЦикла;   
    ТекДанные = Элемент.ТекущиеДанные;
    ТекДанные.ИтогоКВыплате = ТекДанные.НачислениеДЗ + ТекДанные.Начисление2 + ТекДанные.Начисление3 + ...;

   
КонецПроцедуры
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск