Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 июл 2024, 06:10

Перезапись строки в Регистре Накопления

Автор Shaman_blr, 04 дек 2023, 13:39

0 Пользователей и 1 гость просматривают эту тему.

Shaman_blr

Всем привет. Есть документ который перезаписывает уже существующую строку в Регистре накопления. Которая создана из другого документа.

Процедура Использовать(Отказ) Экспорт

Набор = РегистрыНакопления.Использовать.СоздатьНаборЗаписей();
Набор.Отбор.Регистратор.Установить(Регистратор);
Набор.Прочитать();
тз = Набор.Выгрузить();

Для каждого лкСтрока Из Товары Цикл

СтруктураОтбора = Новый Структура;
СтруктураОтбора.Вставить("ПартияСырья", лкСтрока.ПартияСписание);
СтруктураОтбора.Вставить("Партия", лкСтрока.Партия);
НайденныйМассивСтрок = ТЗ.НайтиСтроки(СтруктураОтбора);

Если НайденныйМассивСтрок.Количество() = 0 Тогда
ТекстСообщения = "Отказ в проведении! Данные внесенные в Документ, отсутствуют в регистре Использовать";
ОбщегоНазначения.ОшибкаПриПроведении(ТекстСообщения, Отказ);
Отказ = Истина;
Иначе
Для каждого Строка из НайденныйМассивСтрок Цикл
Строка.КоличествоФакт = Строка.КоличествоФакт + лкСтрока.КоличествоМ; //ед.М
Строка.КоличествоФактДоп = Строка.КоличествоФактДоп + лкСтрока.КоличествоКг; //ед.Кг
КонецЦикла;
Набор.Загрузить(тз);
Набор.Записать();

КонецЕсли;

КонецЦикла;

КонецПроцедуры;


Вопрос: реально ли после отмены проведения сделать так, чтобы строка регистра вернулась так как была до проведения документа?

LexaK

Цитата: Shaman_blr от 04 дек 2023, 13:39Вопрос: реально ли после отмены проведения сделать так, чтобы строка регистра вернулась так как была до проведения документа?
да, реально!

просто при отмене проведения корректирующего документа, перепроведите документ Регистратор
(тот документ чьи проводки вы меняли)
как раз он и восстановит свои первоначальные записи в регистре!

 
если помогло нажмите: Спасибо!

Shaman_blr

LexaK, а есть пример как вызвать тот документ, чтобы он перепровелся сразу?

LexaK

Shaman_blr, пример??? дааа...

РегистраторОбъект.Записать(РежимЗаписиДокумента.Проведение);

куда эту команду добавить, сами найдете? если не получится пишите
(уж подсказывать - так подсказывать.)

(и да в вашем коде зугрузку НЗ из ТЗ вынесите из цикла!)
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск