Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 фев 2024, 08:48

Как преобразовать полученный токен в строку

Автор Vasylii, 29 ноя 2023, 13:29

0 Пользователей и 1 гость просматривают эту тему.

Vasylii

Я получаю токен ОтветСтрокой = Ответ.ПолучитьТелоКакСтроку(); но в результате получаю строку со след данными, как из этих всех данных вытащить только аксес_токен? все данные эти ввиде строки "access_token": "eyJhbGciOiJSUzI1NiIsInR5cCI6IkpXVCJ9.eyJzY29wZSI6WyJvcmRlcjphbGwiLCJwYXltZW50OmFsbCJdLCJleHAiOjE3MDEyNTcyOTYsImF1dGhvcml0aWVzIjpbInNoYXJkLWlkOnJ1LTAxIiwiY2xpZW50LWNpdHk60J3QvtCy0L7RgdC40LHQuNGA0YHQuiwg0J3QvtCy0L7RgdC40LHQuNGA0YHQutCw0Y8g0L7QsdC70LDRgdGC0YwiLCJhY2NvdW50LWxhbmc6cnVzIiwiY29udHJhY3Q60JjQnC3QoNCkLdCT0JvQky0yMiIsImFwaS12ZXJzaW9uOjEuMSIsImFjY291bnQtdXVpZDplOTI1YmQwZi0wNWE2LTRjNTYtYjczNy00Yjk5YzE0ZjY2OWEiLCJjbGllbnQtaWQtZWM1OmVkNzVlY2Y0LTMwZWQtNDE1My1hZmU5LWViODBiYjUxMmYyMiIsImNvbnRyYWN0LWlkOmRlNDJjYjcxLTZjOGMtNGNmNS04MjIyLWNmYjY2MDQ0ZThkZiIsImNsaWVudC1pZC1lYzQ6MTQzNDgyMzEiLCJjb250cmFnZW50LXV1aWQ6ZWQ3NWVjZjQtMzBlZC00MTUzLWFmZTktZWI4MGJiNTEyZjIyIiwic29saWQtYWRkcmVzczpmYWxzZSIsImZ1bGwtbmFtZTrQotC10YHRgtC40YDQvtCy0LDQvdC40LUg0JjQvdGC0LXQs9GA0LDRhtC40Lgg0JjQnCJdLCJqdGkiOiJOQ3ZOT2VIWjV3bXEtS3dKRWpjdUt2UE1tR2siLCJjbGllbnRfaWQiOiJFTXNjZDZyOUpuRmlRM2JMb3lqSlk2ZU03OEpySmNlSSJ9.Cp-OB1ZYs05-q4J0gmKk6On0QJp0CNy4PyCjNbd1YtdYkPkeTQX2mPu39MxtrwzhXcQFkpx_7GLAN5iJ6q1CHZ6tuQGwNk99HOXgQNkDI28GtR_xTtDlsn7zp9KuvhNLupf17OMlzASCpClR2NARdG7wKeRvXXR2jMIf1PtfvDWrLJzG85bySRwG2W4VyIDTYRxK1KB93gYaSfTA0YynWjgUPP8s-G9ExxqMZ2bal5Sqywc91BKYrSCg7z5B2qmbeIGneq_XUQMlNKpKFjAJDp_H2wpIKCyaqKbHS4M-gT39Pbykntlm5MRQKAEYUw_5yUIMtJeGMbmb8wN3tbiMvQ",
    "token_type": "bearer",
    "expires_in": 3599,
    "scope": "order:all payment:all",
    "jti": "NCvNOeHZ5wmq-KwJEjcuKvPMmGk"

antoneus


Vasylii

antoneus, нету разобрался в вопросе написал структуру чтения и обернул все потом в структуру&НаСервере
Функция ПолучитьСтрокуТелаЗапроса(ТелоJSON)

ЧтениеJson = Новый ЧтениеJSON;
ЧтениеJson.УстановитьСтроку(ТелоJSON);
Структура = Новый Структура;
Пока ЧтениеJson.Прочитать() цикл
типJson = ЧтениеJson.ТипТекущегоЗначения;
Если типJson = ТипЗначенияJSON.Число ИЛИ типJson = ТипЗначенияJSON.Строка ИЛИ
типJson = ТипЗначенияJSON.Булево ИЛИ  типJson = ТипЗначенияJSON.Null тогда

Значение = ЧтениеJson.ТекущееЗначение;
ИначеЕсли типJson = ТипЗначенияJSON.Комментарий тогда
Коментарий = ЧтениеJson.ТекущееЗначение
ИначеЕсли типJson = ТипЗначенияJSON.ИмяСвойства тогда
ИмяСвойства = ЧтениеJson.ТекущееЗначение;
ИначеЕсли типJson = ТипЗначенияJSON.НачалоМассива ИЛИ типJson = ТипЗначенияJSON.КонецМассива ИЛИ
типJson = ТипЗначенияJSON.НачалоОбъекта ИЛИ типJson = ТипЗначенияJSON.КонецОбъекта ИЛИ
типJson = ТипЗначенияJSON.Ничего тогда
КонецЕсли;
Если ЗначениеЗаполнено(ИмяСвойства) И ЗначениеЗаполнено(Значение) тогда
Структура.Вставить(ИмяСвойства,Значение);
КонецЕсли;
КонецЦикла;
ЧтениеJson.Закрыть();
Возврат Структура;

КонецФункции

antoneus


Похожие темы (5)

Рейтинг@Mail.ru

Поиск