Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2024, 05:50

Тестирование прикладного решения

Автор Karl, 19 ноя 2023, 07:13

0 Пользователей и 1 гость просматривают эту тему.

Karl

Здравствуйте, подскажите как в автоматизации тестирования сделать чтобы открывалась подсистема?

Сама база данных открывается, а подсистема нет.

Перевел журнал действий пользователя с помощью UILogToScript

Сам код:

 
&НаКлиенте
Процедура ТестовыйСценарий1(Команда)
   
       ЗапуститьСистему("""Платформа"" ENTERPRISE /F " + ПутьКБазе + "  / TESTCLIENT");
       
       ТестируемоеПриложение = Новый ТестируемоеПриложение();
       МаксИтераций = 10;
       Для Счетчик  = 1 По МаксИтераций Цикл
           Попытка
               ТестируемоеПриложение.УстановитьСоединение();
               Прервать;
           Исключение
               Если Счетчик = МаксИтераций Тогда
                   Сообщить(ОписаниеОшибки());
               КонецЕсли;
           КонецПопытки;
       КонецЦикла;
       
       
       ГлавноеОкноФормы = ТестируемоеПриложение.НайтиОбъект(Тип("ТестируемоеОкноКлиентскогоПриложения"));
       КомандныйИнтерфейсГлавногоОкна = ГлавноеОкноФормы.ПолучитьКомандныйИнтерфейс();
       
       КнопкаКомандногоИнтерфейсаСведенияОМатериалеИФарнитуре = ГлавноеОкноФормы.НайтиОбъект(Тип("ТестируемаяКнопкаКомандногоИнтерфейса"), "Сведения о материале и фарнитуре");
       КнопкаКомандногоИнтерфейсаСведенияОМатериалеИФарнитуре.Нажать();
 
       КнопкаКомандногоИнтерфейсаФурнитура =  ГлавноеОкноФормы.НайтиОбъект(Тип("ТестируемаяКнопкаКомандногоИнтерфейса"), "Фурнитура");
       КнопкаКомандногоИнтерфейсаФурнитура.Нажать();
       
       ОкноПриложенияФурнитура = ТестируемоеПриложение.НайтиОбъект(Тип("ТестируемоеОкноКлиентскогоПриложения"), "Фурнитура");
       ОкноПриложенияФурнитураФормаФурнитура = ОкноПриложенияФурнитура.НайтиОбъект(Тип("ТестируемаяФорма"), "Фурнитура");
       КнопкаСоздать = ОкноПриложенияФурнитураФормаФурнитура.НайтиОбъект(Тип("ТестируемаяКнопкаФормы"), "Создать");
       КнопкаСоздать.Нажать();
       
       ОкноПриложенияФурнитураСоздание = ТестируемоеПриложение.НайтиОбъект(Тип("ТестируемоеОкноКлиентскогоПриложения"), "Фурнитура (создание)");
       ОкноПриложенияФурнитураСозданиеФормаФурнитураСоздание = ОкноПриложенияФурнитураСоздание.НайтиОбъект(Тип("ТестируемаяФорма"), "Фурнитура (создание)");
       ПолеНаименование = ОкноПриложенияФурнитураСозданиеФормаФурнитураСоздание.НайтиОбъект(Тип("ТестируемоеПолеФормы"), "Наименование");
       ПолеНаименование.ВвестиТекст("П-образный Кронштейн");
       
       ПолеКоличество = ОкноПриложенияФурнитураСозданиеФормаФурнитураСоздание.НайтиОбъект(Тип("ТестируемоеПолеФормы"), "Количество");
       ПолеКоличество.Активизировать();
 
       ПолеКоличество.ВвестиТекст("1");
 
       ПолеЕдиницаИзмерения = ОкноПриложенияФурнитураСозданиеФормаФурнитураСоздание.НайтиОбъект(Тип("ТестируемоеПолеФормы"), "Единица измерения");
       ПолеЕдиницаИзмерения.Активизировать();
 
       ПолеЕдиницаИзмерения.ОжидатьФормированияВыпадающегоСписка();
 
      ПолеЕдиницаИзмерения.ВыполнитьВыборИзСпискаВыбора("шт");
 
      ПолеТипФурнитуры = ОкноПриложенияФурнитураСозданиеФормаФурнитураСоздание.НайтиОбъект(Тип("ТестируемоеПолеФормы"), "Тип фурнитуры");
      ПолеТипФурнитуры.Активизировать();
 
      ПолеТипФурнитуры.ОжидатьФормированияВыпадающегоСписка();
 
      ПолеТипФурнитуры.ВыполнитьВыборИзСпискаВыбора("Уголки крепежные");
 
      ПолеЦена = ОкноПриложенияФурнитураСозданиеФормаФурнитураСоздание.НайтиОбъект(Тип("ТестируемоеПолеФормы"), "Цена");
      ПолеЦена.Активизировать();
 
      ПолеЦена.ВвестиТекст("30,00");
 
      КнопкаЗаписатьИЗакрыть = ОкноПриложенияФурнитураСозданиеФормаФурнитураСоздание.НайтиОбъект(Тип("ТестируемаяКнопкаФормы"), "Записать и закрыть");
      КнопкаЗаписатьИЗакрыть.Нажать();
   
КонецПроцедуры

Теги:

Похожие темы (2)

Рейтинг@Mail.ru

Поиск