Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 фев 2024, 08:51

Найти текущие данные на сервере

Автор Nosferatu112, 13 ноя 2023, 15:49

0 Пользователей и 1 гость просматривают эту тему.

Nosferatu112

Всем доброго времени суток.
&НаСервере
Функция ВвестиПриказНаОснованииНаСервере()

    НовыйДокумент = Документы.вд_ПриказОРазмереСтоимостиНачислений.СоздатьДокумент();
НовыйДокумент.ТипПЛ = Справочники.вд_ТипПутевогоЛиста.НайтиПоНаименованию(Элементы.Список.ТекущиеДанные.Наименование);
НовыйДокумент.Записать();
Возврат НовыйДокумент.Ссылка;
КонецФункции

&НаКлиенте
Процедура ВвестиПриказНаОсновании(Команда)
СсылкаНаДокумент = ВвестиПриказНаОснованииНаСервере();
ОткрытьЗначение(СсылкаНаДокумент);
КонецПроцедуры
Нужно создать новый док по нажатию кнопки и заполнить в нём реквизит ТипПЛ
Как заполнить этот реквизит если текущие данные на сервере не доступны а мне нужно заполнять строкой которая будет выделенна на данный момент
Если что этот код находиться в форме списка(Справочники.вд_ТипПутевогоЛиста.НайтиПоНаименованию) этого справочника может это как то поможет в вопросе

LexaK

открою секрет, нужные данные можно передавать через параметры,
вот пример
&НаСервере
Функция ВвестиПриказНаОснованииНаСервере(ДанныеЗаполнения)
   
    НовыйДокумент = Документы.вд_ПриказОРазмереСтоимостиНачислений.СоздатьДокумент();
ЗаполнитьЗначенияСвойств(НовыйДокумент, ДанныеЗаполнения);//соблюдаем совпадение имен
    //НовыйДокумент.ТипПЛ = Справочники.вд_ТипПутевогоЛиста.НайтиПоНаименованию(Элементы.Список.ТекущиеДанные.Наименование);
    НовыйДокумент.Записать();
    Возврат НовыйДокумент.Ссылка;
КонецФункции

&НаКлиенте
Процедура ВвестиПриказНаОсновании(Команда)
//получаем данные текущей строки
ТекДанные = элементы.ВашаТаблища.ТекущиеДанные;
Если ТекДанные = Неопределено Тогда
//не выбрана строка, ни чего не делаем
Возврат;
КонецЕсли;

лкПоля = "ИмяПоля1,ИмяПоля2";//через запятую указать имена полей для передачи данных
лкДанные = Новый Структура(лкПоля);
ЗаполнитьЗначенияСвойств(лкДанные, ТекДанные);//помещаем данные в структуру
    СсылкаНаДокумент = ВвестиПриказНаОснованииНаСервере(лкДанные);//передаем данные в процедуру
    ОткрытьЗначение(СсылкаНаДокумент);
КонецПроцедуры
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск