Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2024, 07:21

Шрифт

Автор Shaman_blr, 29 сен 2023, 10:36

0 Пользователей и 1 гость просматривают эту тему.

Shaman_blr

Увеличить шрифт для ТСД.

Всем привет для ТСД нужно увеличить шрифт и кнопки
Скрин как было прилагается.
и как стало с помощью кода.
Код лежит в ГлобальныйМодуль
Процедура ИзменитьШрифт(ИсходныйШрифт, Масштаб)
    //Чтобы избежать повторного увеличения при неоднократном вызове масштабирования
    НовыйМасштаб = (Масштаб/ИсходныйШрифт.Масштаб)*100;
    Если НовыйМасштаб <> 100 Тогда
        ИсходныйШрифт = Новый Шрифт(ИсходныйШрифт,,,,,,,НовыйМасштаб);
    КонецЕсли;
КонецПроцедуры

Процедура ИзменитьМасштабФормы(Форма) Экспорт
   
    //Настройки = НастройкиМасштабированияФорм();
        Настройки = Новый Структура;
        Настройки.Вставить("МасштабЗначенияПоля",300);
        Настройки.Вставить("МасштабЗаголовкаПоля",300);
   
    ТипТаблица = Тип("ТаблицаФормы");
    ТипГруппа = Тип("ГруппаФормы");
   
    Для Каждого ТекущийЭлемент ИЗ Форма.Элементы Цикл
       
        Если ТипЗнч(ТекущийЭлемент) = ТипТаблица Тогда
            //Элементы колонок таблицы наследуют масштаб таблицы + свой масштаб
            //Я вот так решил избежать двойного увеличения
        ИначеЕсли ТипЗнч(ТекущийЭлемент) = ТипГруппа Тогда
            Если ТекущийЭлемент.Вид = ВидГруппыФормы.КоманднаяПанель Тогда
                //Тут есть свои особенности у "Обычного приложения"
            Иначе
                ИзменитьШрифт(ТекущийЭлемент.ШрифтЗаголовка,Настройки.МасштабЗаголовкаПоля);
            КонецЕсли;
        Иначе
            Попытка
                ИзменитьШрифт(ТекущийЭлемент.Шрифт,Настройки.МасштабЗначенияПоля);
               
            Исключение
            КонецПопытки;
           
            Попытка
                ИзменитьШрифт(ТекущийЭлемент.ШрифтЗаголовка,Настройки.МасштабЗаголовкаПоля);
               
            Исключение
            КонецПопытки;
        КонецЕсли;
    КонецЦикла;
   
КонецПроцедуры
А вызывается из формы.
Вопрос таков на скрине видно что нижние поля слева и справа шрифт увеличился а иконки нет. У них Вид = Кнопка. Как для кнопки увеличить масштаб? в свойствах стоит по нулям.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск