Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 мая 2024, 09:52

Фильтры в расшифровке отчета

Автор Дмитрий11, 13 сен 2023, 15:20

0 Пользователей и 1 гость просматривают эту тему.

Дмитрий11

Добрый день! Подскажите возможно ли исправить? Есть отчет,в шапке выставляю фильтр -Организацию и Склад. Как только проваливаюсь в расшифровку отчета, склад остается и становится не активным, а организация сбрасывается на другую и приходится постоянно возвращать.

И можно ли сделать если выбрана организация, то показывал только склады этой организации?

Дмитрий11

&НаСервере
Процедура ПодготовитьОтборыПоСкладам()
МассивСкладов=Обмен.ПодготовитьОтборПоСкладамСкладов(СписокПодразделенийПользователя.ВыгрузитьЗначения());
СписокСкладовПользователя.ЗагрузитьЗначения(МассивСкладов);

Если СписокСкладовПользователя.Количество()>0 Тогда
Для Каждого Эл из СписокСкладовПользователя Цикл
Отчет.Склад=Эл.Значение;
    Прервать;
КонецЦикла;
КонецЕсли;

КонецПроцедуры


Это процедура отбора склада, связки с организацией нет

Максим75

Дмитрий11, если в системе есть связь Организация - склад (там регистр сведений или еще где-то), то прямо в этой процедуре запросом выберите склады по нужной организации и заполните Отчет.Склад

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск