Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 мая 2024, 16:23

Подскажите что нужно написать после если .

Автор ytryh, 23 авг 2023, 17:54

0 Пользователей и 1 гость просматривают эту тему.

ytryh

&НаКлиенте
Процедура Бросок(Команда)
 БроситьКубики()   
КонецПроцедуры

&НаКлиенте
Процедура БроситьКубики()
ГСЧ= Новый ГенераторСлучайныхЧисел;

ЭтотОбъект.числоКубик1=ГСЧ.СлучайноеЧисло(1,6);

ЭтотОбъект.числоКубик2=ГСЧ.СлучайноеЧисло(1,6);





Если  сумма  = 7 или  11 тогда
    Выполнить("вы выигралли")
   
   
      
КонецЕсли;






КонецПроцедуры

antoneus

А что нужно-то? Написать что-либо после если, чтобы что?

ytryh

Мне нужно сделать игру крэпс               я думаю мне нужно сделать 2 переменные и подставить их туда но все равно показывает что неправильно

alexandr_ll

ytryh, Что за переменная "Сумма"и команда "Выполнить"?

LexaK

вот, ученики пошли уже два числа сложить не могут!
вроде элементарно же
&НаКлиенте
Процедура БроситьКубики()
ГСЧ= Новый ГенераторСлучайныхЧисел;

ЭтотОбъект.числоКубик1=ГСЧ.СлучайноеЧисло(1,6);

ЭтотОбъект.числоКубик2=ГСЧ.СлучайноеЧисло(1,6);




Сумма = ЭтотОбъект.числоКубик1 + ЭтотОбъект.числоКубик2; //вот так Сумма считается

Если  сумма = 7 или  сумма = 11 тогда
    Сообщить("вы выиграли: " + сумма);
Иначе   
    Сообщить("вы проиграли: " + сумма);
КонецЕсли;

КонецПроцедуры;
если помогло нажмите: Спасибо!

ytryh

LexaK, спасибо ,я просто никогда не изучал этот язык

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск