Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 мая 2024, 15:39

Доступность Элемента, определенной роли или пользователю

Автор Дмитрий11, 15 авг 2023, 08:51

0 Пользователей и 1 гость просматривают эту тему.

Дмитрий11

Всем привет! Подскажите пожалуйста, на форме сделал реквизит в виде флажка, при постановке флага форма становиться доступна только на просмотр.Как сделать чтобы этот флажок могли снять с определенной ролью?
Сделал так, все работает, но с ролью Админ все равно блокирует
Если Объект.Проверено = Истина Тогда
ЭтотОбъект.ТолькоПросмотр = Истина
КонецЕсли;
Если РольДоступна("АдминистраторСистемы")
Тогда Элементы.Проверено.ТолькоПросмотр = Ложь
КонецЕсли;

fruitella

Попробуйте так

    Если РольДоступна("ПолныеПрава") Тогда
        //Ваш код
    КонецЕсли;

Дмитрий11


fruitella

Цитата: Дмитрий11 от 15 авг 2023, 09:16fruitella, Не сработало

Попробуйте так и проверьте отладкой.

    Если РольДоступна("ПолныеПрава") Тогда
        Элементы.Проверено.Доступность = Истина;
    КонецЕсли;

Дмитрий11

fruitella, тоже пробовал уже, не помогает, работаю всегда через отладку

LexaK

вроде так, форма и ее элементы представляют иерархическую структуру
где настройки распространяются от корня, до элементов
если вы корню (форме) задали только просмотр = Истина, то ВСЕ элементы наследуют этот режим
и уже без разницы что вы там подчиненным элементам назначаете!

теперь понятно почему у вас не работает? и как это исправить?
если помогло нажмите: Спасибо!

Дмитрий11

LexaK, Пока сделал так, поместил все элементы в несколько разных групп и заблокировал их.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск