Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 июл 2024, 05:49

Печатная форма в обработке управляемого приложения

Автор Funt432286, 12 авг 2023, 16:28

0 Пользователей и 1 гость просматривают эту тему.

Funt432286

Всем доброго времени суток!
Что-то как-то с управляемыми приложениями тяжко все идет!
Была разработана обработка под обычное приложение, потом появилась необходимость переделать ее под управляемое приложение. Форму то я переделал!
В данной обработке есть макет печатной формы, которая заполняется из документа по ссылке.
Ни как не могу нормально вызвать команду печати по кнопке с УФ.

// Команда кнопки на форме
&НаКлиенте
Процедура ПечатьЗаявки(Команда)

ПечатьЗаявкиМакет();

КонецПроцедуры


Команда вызова Печатной формы
Функция ПечатьЗаявкиМакет() Экспорт

ТабДок = Новый ТабличныйДокумент;
ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
    Макет = Обработки.Ф_СписокЗаявкаНаСклад.ПолучитьМакет("Ф_ЗаявкаНаОтгрузку");
ТКомпания = Макет.ПолучитьОбласть("ТКомпания");
Заявка = Макет.ПолучитьОбласть("ПолеТаблицы");

ТекСтр = Элементы.ТЧ_СписокЗаявок.ТекущиеДанные;

ТекЯчейки = 2;
КонЯчейки = 3;


Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Ф_ДокЗаявкаНаСкладЗаказы.Ссылка.Дата КАК Дата,
| Ф_ДокЗаявкаНаСкладЗаказы.ТранспортКомпания КАК ТранспортКомпания,
| Ф_ДокЗаявкаНаСкладЗаказы.Заказчик КАК Заказчик,
| Ф_ДокЗаявкаНаСкладЗаказы.Номенклатура КАК Номенклатура,
| Ф_ДокЗаявкаНаСкладЗаказы.Количество КАК Количество,
| Ф_ДокЗаявкаНаСкладЗаказы.Грузополучатель КАК Грузополучатель,
| Ф_ДокЗаявкаНаСкладЗаказы.Плательщик КАК Плательщик,
| Ф_ДокЗаявкаНаСкладЗаказы.АдресДоставки КАК АдресДоставки,
| Ф_ДокЗаявкаНаСкладЗаказы.ДокОтгрузки КАК ДокОтгрузки,
| Ф_ДокЗаявкаНаСкладЗаказы.ТипДоставки КАК ТипДоставки,
| Ф_ДокЗаявкаНаСкладЗаказы.ТипУпаковки КАК ТипУпаковки
|ИЗ
| Документ.Ф_ДокЗаявкаНаСклад.ТЧ_ЗаказыКлиентов КАК Ф_ДокЗаявкаНаСкладЗаказы
|ГДЕ
| Ф_ДокЗаявкаНаСкладЗаказы.Ссылка = &Ссылка
|ИТОГИ ПО
| ТранспортКомпания,
| Заказчик";

Запрос.УстановитьПараметр("Ссылка", ТекСтр.СсылкаЗаявки);

    ...........

Возврат ТабДок;

КонецФункции



ТекСтр.СсылкаЗаявки - это была ссылка на документ из ТЧ в обычной форме

Может кто-нибудь подсказать как вызвать

antoneus

На сервере нет текущих данных, поэтому ссылку нужно получить из текущих данных в процедуре на клиенте и передать ее параметром в серверную функцию формирования табдока.

alexandr_ll

Funt432286,
&НаКлиенте
Процедура ПечатьЗаявки(Команда)
   
    Табдок=ПечатьЗаявкиМакет();
     ТабДок.Показать();
   
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск