Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 мая 2024, 09:34

Задание с Таблицей значений в 1с

Автор Тима22, 11 авг 2023, 11:34

0 Пользователей и 1 гость просматривают эту тему.

Тима22

Приветствую всех. Есть таблица значений, которая содержит только числа. Нужно пройтись по ней и вывести 3 самый больших числа. Есть идеи как можно это реализовать? Благодарю :zebzdr: 

LexaK

Тима22,
1.отсортируйте таблицу по колонке с числами с "убыв"
2.в цикле, выведите первые 3 строчки

уточняющий вопрос: а если в таблице будут одинаковые числа?
и три максимальных числа будут равны - то выводить надо одно число?
или все Три (даже если они одинаковые)?
если помогло нажмите: Спасибо!

Тима22

LexaK, Все три. Есть несколько подразделений, в каждом из них находятся консультанты. Нужно вывести 3 консультантов из каждого подразделения, кто продал (по сумме) больше всего товаров.

LexaK

ааа, задача усложняется
нужна ТЗ с тремя колонками
Подразделение, Консультант, КоличествоПродаж
так как в основном данные получают запросом, то в нем нужно задать и сортировку
добавить команду
"Упорядочить по
таб.Подразделение, таб.КоличествоПродаж убыв"

выгрузить результат запрос в ТЗ и обойти ее циклом примерно так
(возможны другие варианты)
лкТЗ = Запрос.Выполнить().Выгрузить();

лкСчетчик = 0;
текПодр = 0;
Для каждого лкСтр Из лкТЗ Цикл   
Если текПодр <> лкСтр.Подразделение Тогда
//смена подразделения
текПодр = лкСтр.Подразделение;
лкСчетчик = 0;
КонецЕсли;
лкСчетчик = лкСчетчик + 1;
Если лкСчетчик > 3 Тогда
//показано три числа,
Продолжить;
КонецЕсли;

Сообщить("Подразделение: " + лкСтр.Подразделение
+ ", Консультатн: " + лкСтр.Консультатн
+ ", продажи: " + лкСтр.КоличествоПродаж );
КонецЦикла;


(вообще такие задачи делают/решают в виде отчетов, ПродажиПоКонсультантам
там и отборы и сортировки и много еще чего пожно использовать)
если помогло нажмите: Спасибо!

Тима22

LexaK, Май бэд, извиняюсь, не совсем точно описал. Нет колонки "КоличествоПродаж", есть колонка "Сумма"(выводим топ 3 консультантов по Сумме с каждого подразделения). Т.е. 3 консультантов с самым высоким числом в колонке "Сумма". Но спасибо за помощь, дали идею

LexaK

нет колонки КоличествоПродаж !
а есть колонка Сумма

что же делать? что же делать?
попробовать заменить одно наименование на другое (в коде примера)
если помогло нажмите: Спасибо!

Тима22


Теги: 1С Задание 

Похожие темы (5)

Рейтинг@Mail.ru

Поиск