Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 мая 2024, 12:11

Изменение макета 1С ТОиР

Автор gbvdbf, 08 авг 2023, 15:12

0 Пользователей и 1 гость просматривают эту тему.

gbvdbf

Всем привет, появилась проблема с выводом в макет данных. Есть макет, в него добавил новую область ИсполнителиШапка (на скрине, 8 строка), но при печати эта область появляется в самом верху, либо внизу около 36 строки.   

Функция НарядНаРаботы_НеОпасные(МассивОбъектов, ПараметрыПечати, ИмяПФ = "")

ТабДок = Новый ТабличныйДокумент;
ТабДок.ИмяПараметровПечати = "торо_НарядНаВыполнениеРемонтныхРабот";
ТабДок.ТолькоПросмотр = Истина;

Если ИмяПФ = "НарядНаРаботы_сПоказателями" Тогда
Макет = УправлениеПечатью.МакетПечатнойФормы("Документ.торо_НарядНаВыполнениеРемонтныхРабот.ПФ_MXL_НарядНаРаботы_сПоказателями");
Иначе
Макет = УправлениеПечатью.МакетПечатнойФормы("Документ.торо_НарядНаВыполнениеРемонтныхРабот.ПФ_MXL_НарядНаРаботы_НеОпасные");
КонецЕсли;

ИспользоватьКомиссии = Константы.торо_ИспользоватьКомиссии.Получить();
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ РАЗРЕШЕННЫЕ
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка КАК Ссылка,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка.Номер КАК Номер,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка.Дата КАК Дата,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка.Организация КАК Организация,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка.Подразделение КАК Подразделение,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка.Ответственный КАК Ответственный,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ID КАК ID,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ОбъектРемонта КАК ОбъектРемонта,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ОбъектРемонта.Наименование КАК Наименование,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ОбъектРемонта.ТехНомер КАК ТехНомер,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ОбъектРемонта.Комментарий КАК Комментарий,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ОбъектРемонта.АдресМестонахождения КАК АдресМестонахождения,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ВидРемонтныхРабот КАК ВидРемонтныхРабот,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ДатаНачала КАК ДатаНачала,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ДатаОкончания КАК ДатаОкончания,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ОпаснаяРабота КАК ОпаснаяРабота,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.МестоПроведенияРабот КАК МестоПроведенияРабот,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ДокументИсточник КАК ДокументИсточник
|ИЗ
| Документ.торо_НарядНаВыполнениеРемонтныхРабот.РемонтыОборудования КАК торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования
|ГДЕ
| торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка В(&Ссылка)
| И торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ID В(&ID)
|ИТОГИ
| МАКСИМУМ(Номер),
| МАКСИМУМ(Дата),
| МАКСИМУМ(Организация),
| МАКСИМУМ(Подразделение),
| МАКСИМУМ(Ответственный)
|ПО
| Ссылка
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ РАЗРЕШЕННЫЕ
| ВЫБОР
| КОГДА торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота ССЫЛКА Справочник.торо_ТехнологическиеОперации
| ТОГДА ВЫБОР
| КОГДА ВЫРАЗИТЬ(торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК Справочник.торо_ТехнологическиеОперации).НаименованиеПолное = """"
| ТОГДА ВЫРАЗИТЬ(торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК Справочник.торо_ТехнологическиеОперации).Наименование
| ИНАЧЕ ВЫРАЗИТЬ(торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК Справочник.торо_ТехнологическиеОперации).НаименованиеПолное
| КОНЕЦ
| ИНАЧЕ ВЫРАЗИТЬ(торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК Справочник.торо_ИдентификаторыТехКарт).Наименование
| КОНЕЦ КАК РемонтнаяРаботаДляПечати,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК РемонтнаяРабота,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.Количество КАК Количество,
| ВЫРАЗИТЬ(торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК Справочник.торо_ТехнологическиеОперации).БазоваяЕдиницаИзмерения КАК ЕдИзм,
| ВЫРАЗИТЬ(торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК Справочник.торо_ТехнологическиеОперации).СодержаниеРабот КАК СодержаниеРабот,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.Ссылка КАК Ссылка,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтыОборудования_ID КАК РемонтыОборудования_ID,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.ID КАК ID,
| торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.Родитель_ID КАК Родитель_ID
|ИЗ
| Документ.торо_НарядНаВыполнениеРемонтныхРабот.РемонтныеРаботы КАК торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы
|ГДЕ
| торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.Ссылка В(&Ссылка)
| И торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтыОборудования_ID В(&ID)
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ РАЗРЕШЕННЫЕ
| торо_НарядНаВыполнениеРемонтныхРаботИсполнители.Ссылка КАК Ссылка,
| торо_НарядНаВыполнениеРемонтныхРаботИсполнители.Сотрудник.Наименование КАК Сотрудник,
| торо_НарядНаВыполнениеРемонтныхРаботИсполнители.Квалификация.Наименование КАК Квалификация,
| торо_НарядНаВыполнениеРемонтныхРаботИсполнители.РемонтыОборудования_ID КАК РемонтыОборудования_ID,
| торо_НарядНаВыполнениеРемонтныхРаботИсполнители.ID КАК ID
|ПОМЕСТИТЬ ВТ_Исполнители
|ИЗ
| Документ.торо_НарядНаВыполнениеРемонтныхРабот.Исполнители КАК торо_НарядНаВыполнениеРемонтныхРаботИсполнители
|ГДЕ
| торо_НарядНаВыполнениеРемонтныхРаботИсполнители.Ссылка В(&Ссылка)
| И торо_НарядНаВыполнениеРемонтныхРаботИсполнители.РемонтыОборудования_ID В(&ID)
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ РАЗЛИЧНЫЕ
| ВТ_Исполнители.Ссылка КАК Ссылка,
| ВТ_Исполнители.Сотрудник КАК Сотрудник,
| ВТ_Исполнители.Квалификация КАК Квалификация,
| ВТ_Исполнители.РемонтыОборудования_ID КАК РемонтыОборудования_ID
|ИЗ
| ВТ_Исполнители КАК ВТ_Исполнители
|;
|
|////////////////////////////////////////////////////////////////////////////////
|ВЫБРАТЬ РАЗЛИЧНЫЕ
| ВТ_Исполнители.Ссылка КАК Ссылка,
| ВТ_Исполнители.Сотрудник КАК Сотрудник,
| ВТ_Исполнители.Квалификация КАК Квалификация,
| ВТ_Исполнители.РемонтыОборудования_ID КАК РемонтыОборудования_ID,
| ВТ_Исполнители.ID КАК ID
|ИЗ
| ВТ_Исполнители КАК ВТ_Исполнители";   
     
Если ИспользоватьКомиссии Тогда
Запрос.Текст = Запрос.Текст + Символы.ПС + ";" + Символы.ПС + Символы.ПС +
  "ВЫБРАТЬ РАЗРЕШЕННЫЕ
  | торо_КомиссииСоставКомиссии.ЧленКомиссии КАК ЧленКомиссии,
  | торо_НарядНаВыполнениеРемонтныхРабот.Ссылка КАК Ссылка
  |ИЗ
  | Справочник.торо_Комиссии.СоставКомиссии КАК торо_КомиссииСоставКомиссии
  | ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.торо_НарядНаВыполнениеРемонтныхРабот КАК торо_НарядНаВыполнениеРемонтныхРабот
  | ПО торо_КомиссииСоставКомиссии.Ссылка = торо_НарядНаВыполнениеРемонтныхРабот.Комиссия
  |ГДЕ
  | торо_НарядНаВыполнениеРемонтныхРабот.Ссылка В(&Ссылка)";

Запрос.Текст = СтрЗаменить(Запрос.Текст, "&ПредседательКомиссии", "торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка.Комиссия.Председатель КАК ПредседательКомиссии");
Иначе
Запрос.Текст = СтрЗаменить(Запрос.Текст, "&ПредседательКомиссии,", "");
КонецЕсли;

Запрос.УстановитьПараметр("Ссылка", МассивОбъектов);
Если ПараметрыПечати.Свойство("МассивID") Тогда
Запрос.УстановитьПараметр("ID", ПараметрыПечати.МассивID);
Иначе
Запрос.Текст = СтрЗаменить(Запрос.Текст, "И торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ID В(&ID)", "");
Запрос.Текст = СтрЗаменить(Запрос.Текст, "И торо_НарядНаВыполнениеРемонтныхРаботИсполнители.РемонтыОборудования_ID В(&ID)", "");
Запрос.Текст = СтрЗаменить(Запрос.Текст, "И торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтыОборудования_ID В(&ID)", "");
КонецЕсли;

РезультатЗапроса = Запрос.ВыполнитьПакет();

РемонтныеРаботы = РезультатЗапроса[1].Выгрузить();
РемонтныеРаботы.Индексы.Добавить("Ссылка");
РемонтныеРаботы.Индексы.Добавить("РемонтыОборудования_ID");
ВыборкаИсполнителей = РезультатЗапроса[3].Выбрать();
ВыборкаИсполнителейПоРР = РезультатЗапроса[4].Выбрать();

Если ИспользоватьКомиссии Тогда
ВыборкаКомиссий = РезультатЗапроса[5].Выбрать();
КонецЕсли;

ВыборкаДокументов = РезультатЗапроса[0].Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Ссылка");
ЭтоПервый = Истина;
Пока ВыборкаДокументов.Следующий() Цикл 
ВыборкаРемонтов = ВыборкаДокументов.Выбрать(ОбходРезультатаЗапроса.Прямой); 

//////////////////////////////////////////////////////////// ////////
Пока ВыборкаРемонтов.Следующий() Цикл                           ////
РемонтОборудования  = ВыборкаРемонтов;                         ////
                                                               ////
ВывестиИсполнителей(Макет, РемонтОборудования.ID, ТабДок);      ////
    //////////////////////////////////////////////////////////// ///////

обШапка = Макет.ПолучитьОбласть("Шапка");
обШапка.Параметры.Организация = ВыборкаДокументов.Организация;
обШапка.Параметры.Подразделение = ВыборкаДокументов.Подразделение;
обШапка.Параметры.ДатаОткрытия = Формат(ВыборкаДокументов.Дата,"ДФ=dd.MM.yyyy");
обШапка.Параметры.Номер = ВыборкаДокументов.Номер;
обШапка.Параметры.ДатаНачала = Формат(ВыборкаРемонтов.ДатаНачала,"ДФ=dd.MM.yyyy");
обШапка.Параметры.ДатаОкончания = Формат(ВыборкаРемонтов.ДатаОкончания,"ДФ=dd.MM.yyyy");

ПерваяСтрока = Истина;
СтруктураПоиска = Новый Структура("Ссылка, РемонтыОборудования_ID", ВыборкаДокументов.Ссылка, ВыборкаРемонтов.ID);
Пока ВыборкаИсполнителей.НайтиСледующий(СтруктураПоиска) Цикл
Если перваяСтрока Тогда
ПерваяСтрока = Ложь;
обШапка.Параметры.СотрудникИКвалификация = Строка(ВыборкаИсполнителей.Сотрудник) + " (" + ВыборкаИсполнителей.Квалификация + ")";
ТабДок.Вывести(обШапка);
Продолжить;       
КонецЕсли;
    КонецЦикла;

Если ПерваяСтрока Тогда
ТабДок.Вывести(обШапка);
КонецЕсли;

ВывестиРемонты(Макет, ТабДок, РемонтныеРаботы.Скопировать(СтруктураПоиска), ВыборкаРемонтов, ВыборкаИсполнителейПоРР, ИмяПФ);

ПерваяСтрока = Истина;
обИсполнительСЗаголовоком = Макет.ПолучитьОбласть("ИсполнительСЗаголовоком");

ВыборкаИсполнителей.Сбросить();
Пока ВыборкаИсполнителей.НайтиСледующий(СтруктураПоиска) Цикл
Если ПерваяСтрока Тогда
ПерваяСтрока = Ложь;
обИсполнительСЗаголовоком.Параметры.Сотрудник = ВыборкаИсполнителей.Сотрудник;
обИсполнительСЗаголовоком.Параметры.Дата = Формат(ТекущаяДата(),"ДФ='''""''dd''""'' MMMM yyyy ""г.""'");
ПроверитьИВывести(ТабДок, обИсполнительСЗаголовоком);
Продолжить;
КонецЕсли;

обИсполнитель = Макет.ПолучитьОбласть("Исполнитель");
обИсполнитель.Параметры.Сотрудник = ВыборкаИсполнителей.Сотрудник;
обИсполнитель.Параметры.дата = Формат(ТекущаяДата(),"ДФ='''""''dd''""'' MMMM yyyy ""г.""'");
ПроверитьИВывести(ТабДок, обИсполнитель);
КонецЦикла;

Если ПерваяСтрока Тогда
ПроверитьИВывести(ТабДок, обИсполнительСЗаголовоком);
КонецЕсли;

// Комиссия
Если ИспользоватьКомиссии Тогда
ОбластьПредседатель = Макет.ПолучитьОбласть("ПредседательКомиссии");
ОбластьПредседатель.Параметры.ПредседательКомиссии = ВыборкаДокументов.ПредседательКомиссии;
ОбластьПредседатель.Параметры.Дата = Формат(ТекущаяДата(),"ДФ='''""''dd''""'' MMMM yyyy ""г.""'");
ПроверитьИВывести(ТабДок, ОбластьПредседатель);

ПерваяСтрока = Истина;
ОбластьЧленКомиссииСЗаголовком = Макет.ПолучитьОбласть("ЧленКомиссииСЗаголовком");

СтруктураПоискаПоСсылке = Новый Структура("Ссылка", ВыборкаДокументов.Ссылка);
Пока ВыборкаКомиссий.НайтиСледующий(СтруктураПоискаПоСсылке) Цикл
    Если ПерваяСтрока Тогда
ПерваяСтрока = Ложь;
ОбластьЧленКомиссииСЗаголовком.Параметры.ЧленКомиссии = ВыборкаКомиссий.ЧленКомиссии;
ОбластьЧленКомиссииСЗаголовком.Параметры.Дата = Формат(ТекущаяДата(),"ДФ='''""''dd''""'' MMMM yyyy ""г.""'");
ПроверитьИВывести(ТабДок, ОбластьЧленКомиссииСЗаголовком);
Продолжить;
КонецЕсли;

ОбластьЧленКомиссии = Макет.ПолучитьОбласть("ЧленКомиссии");
ОбластьЧленКомиссии.Параметры.ЧленКомиссии = ВыборкаКомиссий.ЧленКомиссии;
ОбластьЧленКомиссии.Параметры.дата = Формат(ТекущаяДата(),"ДФ='''""''dd''""'' MMMM yyyy ""г.""'");
ПроверитьИВывести(ТабДок, ОбластьЧленКомиссии);
КонецЦикла;

Если ПерваяСтрока Тогда
ПроверитьИВывести(ТабДок, ОбластьЧленКомиссииСЗаголовком);
КонецЕсли;

ВыборкаКомиссий.Сбросить();
КонецЕсли;

ВыборкаИсполнителей.Сбросить();
КонецЦикла;     
    /////////////////////////////////////////////////////////////
         КонецЦикла;
    /////////////////////////////////////////////////////////////
ТабДок.КлючПараметровПечати = "торо_НарядНаРаботы_НеОпасные";
Возврат ТабДок;

КонецФункции

Функция НарядНаРаботы_ОднимДокументом (МассивОбъектов, ПараметрыПечати)

ТабДок = Новый ТабличныйДокумент;
ТабДок.ИмяПараметровПечати = "торо_НарядНаВыполнениеРемонтныхРабот";
ТабДок.ТолькоПросмотр = Истина;

Макет = УправлениеПечатью.МакетПечатнойФормы("Документ.торо_НарядНаВыполнениеРемонтныхРабот.ПФ_MXL_НарядНаРаботы_ОднимДокументом");

ИспользоватьКомиссии = Константы.торо_ИспользоватьКомиссии.Получить();
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗРЕШЕННЫЕ
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка КАК Ссылка,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка.Номер КАК Номер,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка.Дата КАК Дата,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка.Организация КАК Организация,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка.Подразделение КАК Подразделение,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка.Ответственный КАК Ответственный,
               | &ПредседательКомиссии,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ID КАК ID,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ОбъектРемонта КАК ОбъектРемонта,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ОбъектРемонта.Наименование КАК Наименование, 
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ОбъектРемонта.АдресМестонахождения КАК АдресМестонахождения,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ВидРемонтныхРабот КАК ВидРемонтныхРабот,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ДатаНачала КАК ДатаНачала,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ДатаОкончания КАК ДатаОкончания,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ОпаснаяРабота КАК ОпаснаяРабота,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.МестоПроведенияРабот КАК МестоПроведенияРабот,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ДокументИсточник КАК ДокументИсточник
               |ИЗ
               | Документ.торо_НарядНаВыполнениеРемонтныхРабот.РемонтыОборудования КАК торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования
               |ГДЕ
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка В(&Ссылка)
               | И торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ID В(&ID)
               |ИТОГИ
               | МАКСИМУМ(Номер),
               | МАКСИМУМ(Дата),
               | МАКСИМУМ(Организация),
               | МАКСИМУМ(Подразделение),
               | МАКСИМУМ(Ответственный)
               |ПО
               | Ссылка
               |;
               |
               |////////////////////////////////////////////////////////////////////////////////
               |ВЫБРАТЬ РАЗРЕШЕННЫЕ
               | ВЫБОР
               | КОГДА торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота ССЫЛКА Справочник.торо_ТехнологическиеОперации
               | ТОГДА ВЫБОР
               | КОГДА ВЫРАЗИТЬ(торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК Справочник.торо_ТехнологическиеОперации).НаименованиеПолное = """"
               | ТОГДА ВЫРАЗИТЬ(торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК Справочник.торо_ТехнологическиеОперации).Наименование
               | ИНАЧЕ ВЫРАЗИТЬ(торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК Справочник.торо_ТехнологическиеОперации).НаименованиеПолное
               | КОНЕЦ
               | ИНАЧЕ ВЫРАЗИТЬ(торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК Справочник.торо_ИдентификаторыТехКарт).Наименование
               | КОНЕЦ КАК РемонтнаяРаботаДляПечати,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК РемонтнаяРабота,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.Количество КАК Количество,
               | ВЫРАЗИТЬ(торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК Справочник.торо_ТехнологическиеОперации).БазоваяЕдиницаИзмерения КАК ЕдИзм,
               | ВЫРАЗИТЬ(торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтнаяРабота КАК Справочник.торо_ТехнологическиеОперации).СодержаниеРабот КАК СодержаниеРабот,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.Ссылка КАК Ссылка,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтыОборудования_ID КАК РемонтыОборудования_ID,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.ID КАК ID,
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.Родитель_ID КАК Родитель_ID
               |ИЗ
               | Документ.торо_НарядНаВыполнениеРемонтныхРабот.РемонтныеРаботы КАК торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы
               |ГДЕ
               | торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.Ссылка В(&Ссылка)
               | И торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтыОборудования_ID В(&ID)
               |;
               |
               |////////////////////////////////////////////////////////////////////////////////
               |ВЫБРАТЬ РАЗРЕШЕННЫЕ
               | торо_НарядНаВыполнениеРемонтныхРаботИсполнители.Ссылка КАК Ссылка,
               | торо_НарядНаВыполнениеРемонтныхРаботИсполнители.Сотрудник.Наименование КАК Сотрудник,
               | торо_НарядНаВыполнениеРемонтныхРаботИсполнители.Квалификация.Наименование КАК Квалификация,
               | торо_НарядНаВыполнениеРемонтныхРаботИсполнители.РемонтыОборудования_ID КАК РемонтыОборудования_ID,
               | торо_НарядНаВыполнениеРемонтныхРаботИсполнители.ID КАК ID
               |ПОМЕСТИТЬ ВТ_Исполнители
               |ИЗ
               | Документ.торо_НарядНаВыполнениеРемонтныхРабот.Исполнители КАК торо_НарядНаВыполнениеРемонтныхРаботИсполнители
               |ГДЕ
               | торо_НарядНаВыполнениеРемонтныхРаботИсполнители.Ссылка В(&Ссылка)
               | И торо_НарядНаВыполнениеРемонтныхРаботИсполнители.РемонтыОборудования_ID В(&ID)
               |;
               |
               |////////////////////////////////////////////////////////////////////////////////
               |ВЫБРАТЬ РАЗЛИЧНЫЕ
               | ВТ_Исполнители.Ссылка КАК Ссылка,
               | ВТ_Исполнители.Сотрудник КАК Сотрудник,
               | ВТ_Исполнители.Квалификация КАК Квалификация
               |ИЗ
               | ВТ_Исполнители КАК ВТ_Исполнители
               |;
               |
               |////////////////////////////////////////////////////////////////////////////////
               |ВЫБРАТЬ РАЗЛИЧНЫЕ
               | ВТ_Исполнители.Ссылка КАК Ссылка,
               | ВТ_Исполнители.Сотрудник КАК Сотрудник,
               | ВТ_Исполнители.Квалификация КАК Квалификация,
               | ВТ_Исполнители.РемонтыОборудования_ID КАК РемонтыОборудования_ID,
               | ВТ_Исполнители.ID КАК ID
               |ИЗ
               | ВТ_Исполнители КАК ВТ_Исполнители";   


Если ИспользоватьКомиссии Тогда
Запрос.Текст = Запрос.Текст + Символы.ПС + ";" + Символы.ПС + Символы.ПС +
  "ВЫБРАТЬ РАЗРЕШЕННЫЕ
  | торо_КомиссииСоставКомиссии.ЧленКомиссии КАК ЧленКомиссии,
  | торо_НарядНаВыполнениеРемонтныхРабот.Ссылка КАК Ссылка
  |ИЗ
  | Справочник.торо_Комиссии.СоставКомиссии КАК торо_КомиссииСоставКомиссии
  | ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.торо_НарядНаВыполнениеРемонтныхРабот КАК торо_НарядНаВыполнениеРемонтныхРабот
  | ПО торо_КомиссииСоставКомиссии.Ссылка = торо_НарядНаВыполнениеРемонтныхРабот.Комиссия
  |ГДЕ
  | торо_НарядНаВыполнениеРемонтныхРабот.Ссылка В(&Ссылка)";

Запрос.Текст = СтрЗаменить(Запрос.Текст, "&ПредседательКомиссии", "торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.Ссылка.Комиссия.Председатель КАК ПредседательКомиссии");
Иначе
Запрос.Текст = СтрЗаменить(Запрос.Текст, "&ПредседательКомиссии,", "");
КонецЕсли;

Запрос.УстановитьПараметр("Ссылка", МассивОбъектов);
Если ПараметрыПечати.Свойство("МассивID") Тогда
Запрос.УстановитьПараметр("ID", ПараметрыПечати.МассивID);
Иначе
Запрос.Текст = СтрЗаменить(Запрос.Текст, "И торо_НарядНаВыполнениеРемонтныхРаботРемонтыОборудования.ID В(&ID)", "");
Запрос.Текст = СтрЗаменить(Запрос.Текст, "И торо_НарядНаВыполнениеРемонтныхРаботИсполнители.РемонтыОборудования_ID В(&ID)", "");
Запрос.Текст = СтрЗаменить(Запрос.Текст, "И торо_НарядНаВыполнениеРемонтныхРаботРемонтныеРаботы.РемонтыОборудования_ID В(&ID)", "");
КонецЕсли;                               



РезультатЗапроса = Запрос.ВыполнитьПакет();
РемонтныеРаботы = РезультатЗапроса[1].Выгрузить();
РемонтныеРаботы.Индексы.Добавить("Ссылка");
РемонтныеРаботы.Индексы.Добавить("РемонтыОборудования_ID");
ВыборкаИсполнителей = РезультатЗапроса[3].Выбрать();
ВыборкаИсполнителейПоРР = РезультатЗапроса[4].Выбрать();

Если ИспользоватьКомиссии Тогда
    ВыборкаКомиссий = РезультатЗапроса[5].Выбрать();
КонецЕсли;

ВыборкаДокументов = РезультатЗапроса[0].Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Ссылка");

Пока ВыборкаДокументов.Следующий() Цикл
обШапка = Макет.ПолучитьОбласть("Шапка");

обШапка.Параметры.Организация = ВыборкаДокументов.Организация;
обШапка.Параметры.Подразделение = ВыборкаДокументов.Подразделение;

обШапка.Параметры.ДатаОткрытия = Формат(ВыборкаДокументов.Дата,"ДФ=dd.MM.yyyy");
обШапка.Параметры.Номер = ВыборкаДокументов.Номер;

ПерваяСтрока = Истина;
СтруктураПоискаПоСсылке = Новый Структура("Ссылка", ВыборкаДокументов.Ссылка);
Пока ВыборкаИсполнителей.НайтиСледующий(СтруктураПоискаПоСсылке) Цикл
Если перваяСтрока Тогда
ПерваяСтрока = Ложь;
обШапка.Параметры.СотрудникИКвалификация = Строка(ВыборкаИсполнителей.Сотрудник) + " (" + ВыборкаИсполнителей.Квалификация + ")";
ТабДок.Вывести(обШапка);
Продолжить;
КонецЕсли;

обСотрудник = Макет.ПолучитьОбласть("Сотрудник");
обСотрудник.Параметры.СотрудникИКвалификация = Строка(ВыборкаИсполнителей.Сотрудник) + " (" + ВыборкаИсполнителей.Квалификация + ")";

ПроверитьИВывести(ТабДок, обСотрудник);
КонецЦикла;

Если ПерваяСтрока Тогда
ТабДок.Вывести(обШапка);
КонецЕсли;

ВыборкаРемонтов = ВыборкаДокументов.Выбрать();
Пока ВыборкаРемонтов.Следующий() Цикл
СтруктураПоиска = Новый Структура("Ссылка, РемонтыОборудования_ID", ВыборкаДокументов.Ссылка, ВыборкаРемонтов.ID);
ВывестиРемонты(Макет, ТабДок, РемонтныеРаботы.Скопировать(СтруктураПоиска), ВыборкаРемонтов, ВыборкаИсполнителейПоРР, "НарядНаРаботы_ОднимДокументом");
КонецЦикла;

обОтветственный = Макет.ПолучитьОбласть("Ответственный");
обОтветственный.Параметры.Сотрудник = ВыборкаДокументов.Ответственный;
обОтветственный.Параметры.Дата = Формат(ТекущаяДата(),"ДФ='''""''dd''""'' MMMM yyyy ""г.""'");
ПроверитьИВывести(ТабДок, обОтветственный);

ПерваяСтрока = Истина;
обИсполнительСЗаголовоком = Макет.ПолучитьОбласть("ИсполнительСЗаголовоком");

ВыборкаИсполнителей.Сбросить();
Пока ВыборкаИсполнителей.НайтиСледующий(СтруктураПоискаПоСсылке) Цикл
Если ПерваяСтрока Тогда
ПерваяСтрока = Ложь;
обИсполнительСЗаголовоком.Параметры.Сотрудник = ВыборкаИсполнителей.Сотрудник;
обИсполнительСЗаголовоком.Параметры.Дата = Формат(ТекущаяДата(),"ДФ='''""''dd''""'' MMMM yyyy ""г.""'");
ПроверитьИВывести(ТабДок, обИсполнительСЗаголовоком);
Продолжить;
КонецЕсли;

обИсполнитель = Макет.ПолучитьОбласть("Исполнитель");
обИсполнитель.Параметры.Сотрудник = ВыборкаИсполнителей.Сотрудник;
обИсполнитель.Параметры.дата = Формат(ТекущаяДата(),"ДФ='''""''dd''""'' MMMM yyyy ""г.""'");
ПроверитьИВывести(ТабДок, обИсполнитель);
КонецЦикла;

Если ПерваяСтрока Тогда
ПроверитьИВывести(ТабДок, обИсполнительСЗаголовоком);
КонецЕсли;

// Комиссия
Если ИспользоватьКомиссии Тогда
ОбластьПредседатель = Макет.ПолучитьОбласть("ПредседательКомиссии");
ОбластьПредседатель.Параметры.ПредседательКомиссии = ВыборкаДокументов.ПредседательКомиссии;
ОбластьПредседатель.Параметры.Дата = Формат(ТекущаяДата(),"ДФ='''""''dd''""'' MMMM yyyy ""г.""'");
ПроверитьИВывести(ТабДок, ОбластьПредседатель);

ПерваяСтрока = Истина;
ОбластьЧленКомиссииСЗаголовком = Макет.ПолучитьОбласть("ЧленКомиссииСЗаголовком");

Пока ВыборкаКомиссий.НайтиСледующий(СтруктураПоискаПоСсылке) Цикл
    Если ПерваяСтрока Тогда
ПерваяСтрока = Ложь;
ОбластьЧленКомиссииСЗаголовком.Параметры.ЧленКомиссии = ВыборкаКомиссий.ЧленКомиссии;
ОбластьЧленКомиссииСЗаголовком.Параметры.Дата = Формат(ТекущаяДата(),"ДФ='''""''dd''""'' MMMM yyyy ""г.""'");
ПроверитьИВывести(ТабДок, ОбластьЧленКомиссииСЗаголовком);
Продолжить;
КонецЕсли;

ОбластьЧленКомиссии = Макет.ПолучитьОбласть("ЧленКомиссии");
ОбластьЧленКомиссии.Параметры.ЧленКомиссии = ВыборкаКомиссий.ЧленКомиссии;
ОбластьЧленКомиссии.Параметры.дата = Формат(ТекущаяДата(),"ДФ='''""''dd''""'' MMMM yyyy ""г.""'");
ПроверитьИВывести(ТабДок, ОбластьЧленКомиссии);
КонецЦикла;

Если ПерваяСтрока Тогда
ПроверитьИВывести(ТабДок, ОбластьЧленКомиссииСЗаголовком);
КонецЕсли;

ВыборкаКомиссий.Сбросить();
КонецЕсли;

ВыборкаИсполнителей.Сбросить();
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЦикла;

ТабДок.КлючПараметровПечати = "торо_НарядНаРаботы_ОднимДокументом";
Возврат ТабДок;

КонецФункции


///А.Н./////////////////////////////////////////////////////////////
Процедура ВывестиИсполнителей(Макет, ID, ТабДок)
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| торо_НарядНаВыполнениеРемонтныхРаботИсполнителиПоРемонтам.Исполнитель КАК Исполнитель
|ИЗ
| Документ.торо_НарядНаВыполнениеРемонтныхРабот.ИсполнителиПоРемонтам КАК торо_НарядНаВыполнениеРемонтныхРаботИсполнителиПоРемонтам
|ГДЕ
|   торо_НарядНаВыполнениеРемонтныхРаботИсполнителиПоРемонтам.РемонтыОборудования_ID = &ID";
Запрос.УстановитьПараметр("ID", ID);
Выборка = Запрос.Выполнить().Выбрать();
ИсполнительЗаполнен = Ложь;
Пока Выборка.Следующий() Цикл
Если Не ИсполнительЗаполнен Тогда
Область = Макет.ПолучитьОбласть("ИсполнителиШапка");
КонецЕсли;
Область.Параметры.Исполнитель = Выборка.Исполнитель;
ТабДок.Вывести(Область); 
КонецЦикла;
КонецПроцедуры 
///А.Н./////////////////////////////////////////////////////////////

Процедура ВывестиРемонты(Макет, ТабДок, тчРемРаботы, ВыборкаРемонтов, ВыборкаИсполнителейПоРР, ИмяПФ = "")



НайС = тчРемРаботы.НайтиСтроки(Новый Структура("Родитель_ID", ""));
Дерево = Новый ДеревоЗначений;
Дерево.Колонки.Добавить("РемонтнаяРабота");
Дерево.Колонки.Добавить("РемонтыОборудования_ID");
Дерево.Колонки.Добавить("ID");
Дерево.Колонки.Добавить("Количество");
Дерево.Колонки.Добавить("НомерОперацииПоПорядку");

НужноПолучитьНормыЗапчастей = Истина;

// Затраты из сметы
СтруктураЗатратИзСметы = Новый Структура("РемонтныеРаботыИзСметы, СтруктураТаблиц", Новый Массив, Новый Структура);
Если ТипЗнч(ВыборкаРемонтов.ДокументИсточник) = Тип("ДокументСсылка.торо_ЗаявкаНаРемонт") Тогда
    СтруктураЗатратИзСметы = ПолучитьНормыЗатратИзСметы(тчРемРаботы, ВыборкаРемонтов, ВыборкаРемонтов.ДокументИсточник);
НужноПолучитьНормыЗапчастей = Ложь;
КонецЕсли;

РемонтныеРаботыИзСметы = СтруктураЗатратИзСметы.РемонтныеРаботыИзСметы;

Для каждого текСтрока Из НайС Цикл
Если Не РемонтныеРаботыИзСметы.Найти(текСтрока.ID) = Неопределено Тогда
Продолжить;
КонецЕсли;
нс = Дерево.Строки.Добавить();
ЗаполнитьЗначенияСвойств(нс, текСтрока);
СобратьДерево(нс, тчРемРаботы, РемонтныеРаботыИзСметы);
КонецЦикла;

торо_ЗаполнениеДокументов20.ПроставитьНомераОпераций(Дерево);

// Затраты из нормативов
стрЗатрат = торо_Ремонты.ПолучитьНормыЗатратИзВетвиДереваОпераций(Дерево, ВыборкаРемонтов.ДатаНачала, ВыборкаРемонтов.ДатаОкончания, ВыборкаРемонтов.ДатаНачала,,,Истина);

тчМатЗатраты = Новый ТаблицаЗначений;
тчМатЗатраты.Колонки.Добавить("Наименование");
тчМатЗатраты.Колонки.Добавить("Характеристика");
тчМатЗатраты.Колонки.Добавить("ЕдИзм");
тчМатЗатраты.Колонки.Добавить("Количество");

тчИнструменты = Новый ТаблицаЗначений;
тчИнструменты.Колонки.Добавить("Наименование");
тчИнструменты.Колонки.Добавить("ЕдИзм");
тчИнструменты.Колонки.Добавить("Количество");

Для каждого текСтрока Из СтрЗатрат Цикл
МатЗатраты = текСтрока.СтруктураТаблиц.МатериальныеЗатраты;
Инструменты = текСтрока.СтруктураТаблиц.ИнструментыИТехника;

Для каждого текСтрокаТЧ Из МатЗатраты Цикл
нс = тчМатЗатраты.Добавить();
нс.Наименование = текСтрокаТЧ.Номенклатура;
нс.Характеристика = текСтрокаТЧ.Характеристика;
нс.ЕдИзм = текСтрокаТЧ.Номенклатура.ЕдиницаИзмерения;
нс.Количество = текСтрокаТЧ.Количество;
КонецЦикла;

Для каждого текСтрокаТЧ Из Инструменты Цикл
нс = тчИнструменты.Добавить();
нс.Наименование = текСтрокаТЧ.Инструмент;
нс.ЕдИзм = текСтрокаТЧ.Инструмент.ЕдиницаИзмерения;
нс.Количество = текСтрокаТЧ.Количество;
КонецЦикла;
КонецЦикла;

Если СтруктураЗатратИзСметы.СтруктураТаблиц.Количество() > 0 Тогда
МатериальныеЗатраты = СтруктураЗатратИзСметы.СтруктураТаблиц.МатериальныеЗатраты;
Инструменты = СтруктураЗатратИзСметы.СтруктураТаблиц.ИнструментыИТехника;

Для каждого СтрокаЗатрат Из МатериальныеЗатраты Цикл
НоваяСтрокаЗатрат = тчМатЗатраты.Добавить();
НоваяСтрокаЗатрат.Наименование = СтрокаЗатрат.Номенклатура;
НоваяСтрокаЗатрат.Характеристика = СтрокаЗатрат.ХарактеристикаНоменклатуры;
НоваяСтрокаЗатрат.ЕдИзм = СтрокаЗатрат.ЕдиницаИзмерения;
НоваяСтрокаЗатрат.Количество = СтрокаЗатрат.Количество;
КонецЦикла;

Для каждого СтрокаИнструментов Из Инструменты Цикл
НоваяСтрокаИнструментов = тчИнструменты.Добавить();
НоваяСтрокаИнструментов.Наименование = СтрокаИнструментов.Инструмент;
НоваяСтрокаИнструментов.ЕдИзм = СтрокаИнструментов.ЕдиницаИзмерения;
НоваяСтрокаИнструментов.Количество = СтрокаИнструментов.Количество;
КонецЦикла;
КонецЕсли;

// Если наряд не на основании сметы, то запчасти нужно брать из ОР
Если НужноПолучитьНормыЗапчастей Тогда
    НормыЗапчастей = ПолучитьНормыЗапчастей(ВыборкаРемонтов.ОбъектРемонта, ВыборкаРемонтов.ВидРемонтныхРабот);
Для каждого СтрокаЗапчасти Из НормыЗапчастей Цикл
    НоваяСтрокаЗатрат = тчМатЗатраты.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрокаЗатрат, СтрокаЗапчасти);
КонецЦикла;
КонецЕсли;

тчМатЗатраты.Свернуть("Наименование, Характеристика, ЕдИзм", "Количество");
тчИнструменты.Свернуть("Наименование, ЕдИзм", "Количество");

обОписаниеОР = Макет.ПолучитьОбласть("ОписаниеОР");
Если ИмяПФ = "НарядНаРаботы_ОднимДокументом" Тогда
обОписаниеОР.Параметры.ДатаНачала = Формат(ВыборкаРемонтов.ДатаНачала,"ДФ=dd.MM.yyyy");
обОписаниеОР.Параметры.ДатаОкончания = Формат(ВыборкаРемонтов.ДатаОкончания,"ДФ=dd.MM.yyyy");

КонецЕсли;
обОписаниеОР.Параметры.ОР = торо_ЗаполнениеДокументов.ПолучитьПредоставленияОРДляПечати(ВыборкаРемонтов.ОбъектРемонта);
обОписаниеОР.Параметры.Местонахождение = ВыборкаРемонтов.АдресМестонахождения;
обОписаниеОР.Параметры.ТехНомер = ВыборкаРемонтов.ТехНомер;
обОписаниеОР.Параметры.Комментарий = ВыборкаРемонтов.Комментарий;
    обОписаниеОР.Параметры.Описание = ВыборкаРемонтов.ВидРемонтныхРабот;
ПроверитьИВывести(ТабДок, обОписаниеОР);

обШапкаТЧСостав = Макет.ПолучитьОбласть("ШапкаТЧСостав");
ПроверитьИВывести(ТабДок, обШапкаТЧСостав);

СтрокиВКорне = тчРемРаботы.НайтиСтроки(Новый структура("Родитель_ID", ""));
ВывестиРекурсивно(Макет, тчРемРаботы, СтрокиВКорне, ТабДок, "СтрокаТЧСостав", "", ВыборкаИсполнителейПоРР);

  ИспользоватьХарактеристики = Константы.торо_ИспользоватьХарактеристикиНоменклатуры.Получить();
Если ИспользоватьХарактеристики Тогда
обШапкаТЧМатериалы = Макет.ПолучитьОбласть("ШапкаТЧМатериалыФО");
обСтрокаТЧМатериалы = Макет.ПолучитьОбласть("СтрокаТЧМатериалыФО");
Иначе
обШапкаТЧМатериалы = Макет.ПолучитьОбласть("ШапкаТЧМатериалы");
обСтрокаТЧМатериалы = Макет.ПолучитьОбласть("СтрокаТЧМатериалы");
КонецЕсли;
ПроверитьИВывести(ТабДок, обШапкаТЧМатериалы);   


номерПП = 1;
Для каждого текСтрока из тчМатЗатраты Цикл
обСтрокаТЧМатериалы.Параметры.Ном = НомерПП;
обСтрокаТЧМатериалы.Параметры.Наименование = текСтрока.Наименование;
Если ИспользоватьХарактеристики Тогда
обСтрокаТЧМатериалы.Параметры.Характеристика = текСтрока.Характеристика;
КонецЕсли;
обСтрокаТЧМатериалы.Параметры.ЕдИзм = текСтрока.ЕдИзм;
обСтрокаТЧМатериалы.Параметры.Количество = текСтрока.Количество;

НомерПП = НомерПП + 1;
ПроверитьИВывести(ТабДок, обСтрокаТЧМатериалы);
КонецЦикла;

обШапкаТЧИнструменты = Макет.ПолучитьОбласть("ШапкаТЧИнструменты");
ПроверитьИВывести(ТабДок, обШапкаТЧИнструменты);

НомерПП = 1;
Для каждого ТекСтрока Из тчИнструменты Цикл
обСтрокаТЧИнструменты = Макет.ПолучитьОбласть("СтрокаТЧИнструменты");
обСтрокаТЧИнструменты.Параметры.Ном = НомерПП;
обСтрокаТЧИнструменты.Параметры.Наименование = ТекСтрока.Наименование;
обСтрокаТЧИнструменты.Параметры.ЕдИзм = ТекСтрока.ЕдИзм;
обСтрокаТЧИнструменты.Параметры.Количество = ТекСтрока.Количество;

НомерПП = НомерПП + 1;
ПроверитьИВывести(ТабДок, обСтрокаТЧИнструменты); 

КонецЦикла;

КонтрПоказатели = ПланыВидовХарактеристик.торо_ИзмеряемыеПоказателиОбъектовРемонта.ПолучитьСтруктуруИзмеряемыхПоказателейОбъектовРемонта(ВыборкаРемонтов.ОбъектРемонта);
Если ИмяПФ = "НарядНаРаботы_сПоказателями" И КонтрПоказатели.Количество() > 0 Тогда
обШапкаТЧПоказатели = Макет.ПолучитьОбласть("ШапкаТЧПоказатели");
ПроверитьИВывести(ТабДок, обШапкаТЧПоказатели);

НомерПП = 1;
Для каждого Строка Из КонтрПоказатели Цикл
Если НЕ Строка.Удален Тогда
обСтрокаТЧПоказатели = Макет.ПолучитьОбласть("СтрокаТЧПокзатели");
обСтрокаТЧПоказатели.Параметры.Ном = НомерПП;
обСтрокаТЧПоказатели.Параметры.Показатель = Строка.Показатель;

НомерПП = НомерПП + 1;
ПроверитьИВывести(ТабДок, обСтрокаТЧПоказатели);
КонецЕсли;
КонецЦикла;

КонецЕсли;

КонецПроцедуры

Процедура ВывестиРекурсивно(Макет, ТЧ, Мас, ТабДок, ИмяОбластиВМакете, НомерРодителя, ВыборкаИсполнителейПоРР)

Максим75

gbvdbf, так где ВывестиИсполнителей поместили, там и выводит эту область.
Вы же до вывода шапки поместили.

вот кусок Вашего кода:

 ВывестиИсполнителей(Макет, РемонтОборудования.ID, ТабДок);         ////
    //////////////////////////////////////////////////////////// ///////
   
            обШапка = Макет.ПолучитьОбласть("Шапка");

где указали, там и выводит.

gbvdbf

Максим75, спасибо) нашел) пропустил нужную строку, ниже вставлял.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск