Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 мая 2024, 16:29

Ошибка «Отсутствует отображение для типа (ФормаКлиентскогоПриложения)»

Автор Sekeretteni, 14 июл 2023, 10:42

0 Пользователей и 1 гость просматривают эту тему.

Sekeretteni

Добрый день!
После обновления релиза в бухгалтерии возникает ошибка: Ошибка «Отсутствует отображение для типа (ФормаКлиентскогоПриложения)»

изменилась процедура, как я понимаю, проблема в том, что не нужно дополнительно передавать форму. Подскажите, пожалуйста, как можно исправить?

до обновления:

&НаКлиентеНаСервереБезКонтекста
Процедура ЗаполнитьПредставлениеАналитикиУчетаЗатратВШапке(Форма)

Объект = Форма.Объект;

Если Объект.СчетаУчетаЗатратВТаблице Тогда
  Форма.АналитикаУчетаЗатрат = НСтр("ru = 'В списке'");
Иначе
  ДанныеАналитики = Новый Структура("СчетЗатрат, ПодразделениеЗатрат, Субконто1, Субконто2, Субконто3, СпособУчетаНДС, СчетаУчетаЗатратВТаблице");
  ЗаполнитьЗначенияСвойств(ДанныеАналитики, Объект);
  ДанныеАналитики.Вставить("РаздельныйУчетНДСНаСчете19", Форма.РаздельныйУчетНДСНаСчете19);
  Форма.АналитикаУчетаЗатрат = ПредставлениеАналитикиУчетаЗатрат(ДанныеАналитики);
КонецЕсли;

КонецПроцедуры

после обновления:

&НаСервереБезКонтекста
Процедура ЗаполнитьПредставлениеАналитикиУчетаЗатратВШапке(Форма)
   
    Объект = Форма.Объект;
   
    Если Объект.СчетаУчетаЗатратВТаблице Тогда
        Форма.АналитикаУчетаЗатрат = НСтр("ru = 'В списке'");
    Иначе
       
        ДанныеАналитики = НовыйДанныеАналитики();
        ЗаполнитьЗначенияСвойств(ДанныеАналитики, Объект);
        ДанныеАналитики.РаздельныйУчетНДСНаСчете19 = Форма.РаздельныйУчетНДСНаСчете19;
       
        Форма.АналитикаУчетаЗатрат = БухгалтерскийУчет.ПредставлениеАналитикиУчетаЗатрат(ДанныеАналитики);
       
    КонецЕсли;
   
КонецПроцедуры

Sekeretteni

не актуально
оказалось, что ошибка проявлялась раньше - передавалась форма с клиента на сервер, вынесла в отдельную процедуру, ошибка ушла

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск