Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 фев 2024, 15:24

Ошибка в расширении 1С:Комплексная автоматизация 2 (2.5.12.60)

Автор yoshicity, 13 июл 2023, 14:08

0 Пользователей и 1 гость просматривают эту тему.

yoshicity

 :lol:

Ошибка:
{АвтоматическоеСозданиеПКО ОбщийМодуль.РозничныеПродажи.Модуль(2,2)}: Ожидается оператор препроцессора
#<<?>>Использовать ПриходныйКассовыйОрдерЛокализация   (Проверка: Сервер)



&После ("ВыполнитьАвтоматическуюИнкассациюДС")
#Использовать ПриходныйКассовыйОрдерЛокализация 
Процедура Автоматическое_СозданиеПКО_ПриЗакрытииСмены(КассаККМ, ОшибкаПриСнятииZОтчета) Экспорт

    // Запрос для поиска последней выемки денежных средств
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ ПЕРВЫЕ 1
        |   ВыемкаДенежныхСредствИзКассыККМ.Ссылка КАК Ссылка
        |ИЗ
        |   Документ.ВыемкаДенежныхСредствИзКассыККМ КАК ВыемкаДенежныхСредствИзКассыККМ
        |ГДЕ
        |   ВыемкаДенежныхСредствИзКассыККМ.Проведен
        |УПОРЯДОЧИТЬ ПО
        |   Дата УБЫВ";

    // Выполняем запрос и получаем ссылку на последнюю проведенную выемку
    РезультатЗапроса = Запрос.Выполнить();
    Если РезультатЗапроса.Пустой() Тогда
        Возврат;
    КонецЕсли;
    Выборка = РезультатЗапроса.Выбрать();
    Выборка.Следующий();
    ПоследняяВыемка = Выборка.Ссылка;

    Если ЗначениеЗаполнено(ПоследняяВыемка) Тогда

        // Создаем объект ПКО
        ПКО = Документы.ПриходныйКассовыйОрдер.СоздатьДокумент();
        // Заполняем ПКО на основании последней выемки
        ПриходныйКассовыйОрдерЛокализация.ЗаполнитьПоВыемкеДенежныхСредствИзКассыККМ(ПКО, ПоследняяВыемка);

        // Запись и проведение ПКО
        ПКО.Записать(РежимЗаписиДокумента.Проведение);

        // Вывод информации о созданном ПКО
        Сообщить("ПКО успешно создан на основе последней выемки денежных средств.");
    КонецЕсли;
КонецПроцедуры

Rettro

yoshicity, https://its.1c.ru/db/v8std/content/439/hdoc

: Использование конструкций встроенного языка :: Система стандартов и методик разработки конфигураций для платформы 1С:Предприятие 8


Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск