Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 мая 2024, 15:32

Предопределенное значение и работа с расширением

Автор Дмитрий11, 04 июл 2023, 09:15

0 Пользователей и 1 гость просматривают эту тему.

Дмитрий11

Всем привет, подскажите пожалуйста, конфа на поддержке, необходимо реквизиту установить предопределенное значение, в свойствах реквизита,если делать через расширение, этот пункт не доступен. Через модуль попробовал вставить в

&НаКлиенте
Процедура ПриОткрытии(Отказ)
   Объект.МойОбъект=ПредопределенноеЗначение("Перечисления.МоиПеречесления.Запретить");
КонецПроцедуры

НО после проводки документа значение не сохраняется и при каждым открытии меняется на Запретить, как сделать чтобы ,если выбрали Разрешить,после записи документа это значение оставалось.Спасибо!

Максим75

Дмитрий11, так проверяйте на ЗначениеЗаполнено(), если пустое - то заполняйте предопределенным.

LexaK

Дмитрий11,
Цитироватьи при каждым открытии меняется на Запретить,

и у вас код
&НаКлиенте
Процедура ПриОткрытии(Отказ)
   Объект.МойОбъект=ПредопределенноеЗначение("Перечисления.МоиПеречесления.Запретить");
КонецПроцедуры

тут вы ЯВНО задаете значение Запретить - КАЖДЫЙ РАЗ!

добавьте проверку, например такую

&НаКлиенте
Процедура ПриОткрытии(Отказ)
  Если Не ЗначениеЗаполнено(Объект.МойОбъект) Тогда
   Объект.МойОбъект=ПредопределенноеЗначение("Перечисления.МоиПеречесления.Запретить");
  КонецЕсли;
КонецПроцедуры
если помогло нажмите: Спасибо!

Дмитрий11

LexaK, Не получилось, потому что уже по умолчанию в свойствах основного реквизита стоит значение заполнения "Разрешить", а в расширении его изменить не могу, поэтому поле уже не пустое изначально

LexaK

Дмитрий11, попробуйте проверять Объект.Ссылка - если это новый документ, она должна быть пустой, тогда примерно так
&НаКлиенте
Процедура ПриОткрытии(Отказ)
  Если Не ЗначениеЗаполнено(Объект.Ссылка) Тогда
   Объект.МойОбъект=ПредопределенноеЗначение("Перечисления.МоиПеречесления.Запретить");
  КонецЕсли;
КонецПроцедуры
если помогло нажмите: Спасибо!

Дмитрий11


Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск