Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 мая 2024, 09:19

Выводятся все документы подряд в печатную форму, а нужен только один

Автор steeld, 25 июн 2023, 21:55

0 Пользователей и 1 гость просматривают эту тему.

steeld

Код команды:

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
//{{_КОНСТРУКТОР_ПЕЧАТИ(Стационарная)
ТабДок = Новый ТабличныйДокумент;
Стационарная(ТабДок, ПараметрКоманды);

ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Истина;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.Показать();
//}}
КонецПроцедуры

&НаСервере
Процедура Стационарная(ТабДок, ПараметрКоманды)
Документы.МедицинскаяКарта.Стационарная(ТабДок, ПараметрКоманды);
КонецПроцедуры

Код в модуле менеджера:

Процедура Стационарная(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Стационарная)
Макет = Документы.МедицинскаяКарта.ПолучитьМакет("Стационарная");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| МедицинскаяКарта.Ссылка КАК Ссылка,
| МедицинскаяКарта.ВерсияДанных КАК ВерсияДанных,
| МедицинскаяКарта.ПометкаУдаления КАК ПометкаУдаления,
| МедицинскаяКарта.Номер КАК Номер,
| МедицинскаяКарта.Дата КАК Дата,
| МедицинскаяКарта.Проведен КАК Проведен,
| МедицинскаяКарта.Тип КАК Тип,
| МедицинскаяКарта.ДатаПоступления КАК ДатаПоступления,
| МедицинскаяКарта.ДатаВыписки КАК ДатаВыписки,
| МедицинскаяКарта.Отделение КАК Отделение,
| МедицинскаяКарта.Палата КАК Палата,
| МедицинскаяКарта.ПроведеноВОтделении КАК ПроведеноВОтделении,
| МедицинскаяКарта.ВидТранспортировки КАК ВидТранспортировки,
| МедицинскаяКарта.ГруппаКрови КАК ГруппаКрови,
| МедицинскаяКарта.ПобочноеДействиеЛекарств КАК ПобочноеДействиеЛекарств,
| МедицинскаяКарта.АдресПроживания КАК АдресПроживания,
| МедицинскаяКарта.Пол КАК Пол,
| МедицинскаяКарта.ДатаРождения КАК ДатаРождения,
| МедицинскаяКарта.Возраст КАК Возраст,
| МедицинскаяКарта.СНИЛС КАК СНИЛС,
| МедицинскаяКарта.Пациент КАК Пациент,
| МедицинскаяКарта.НомерПолиса КАК НомерПолиса,
| МедицинскаяКарта.ДиагнозКлинический КАК ДиагнозКлинический,
| МедицинскаяКарта.КодДиагноза КАК КодДиагноза,
| МедицинскаяКарта.ДатаУстановления КАК ДатаУстановления,
| МедицинскаяКарта.Фамилия КАК Фамилия,
| МедицинскаяКарта.Имя КАК Имя,
| МедицинскаяКарта.Отчетство КАК Отчетство,
| МедицинскаяКарта.КемНаправлен КАК КемНаправлен,
| МедицинскаяКарта.ГруппаИнвалидности КАК ГруппаИнвалидности,
| МедицинскаяКарта.Инвалидность КАК Инвалидность,
| МедицинскаяКарта.МестоРаботы КАК МестоРаботы,
| МедицинскаяКарта.Трудоспособность КАК Трудоспособность,
| МедицинскаяКарта.ИсходЗаболевания КАК ИсходЗаболевания,
| МедицинскаяКарта.Учреждение КАК Учреждение,
| МедицинскаяКарта.Пользователь КАК Пользователь,
| МедицинскаяКарта.КодЛьготы КАК КодЛьготы,
| МедицинскаяКарта.Стадия КАК Стадия,
| МедицинскаяКарта.ДатаНачалаДиспНаблюдения КАК ДатаНачалаДиспНаблюдения,
| МедицинскаяКарта.ДатаПрекрДиспНаблюдения КАК ДатаПрекрДиспНаблюдения,
| МедицинскаяКарта.Врач КАК Врач,
| МедицинскаяКарта.Операции.(
| СсылкаНаДокумент.Врач КАК СсылкаНаДокументВрач,
| СсылкаНаДокумент.Терапия КАК СсылкаНаДокументТерапия,
| СсылкаНаДокумент.Операция КАК СсылкаНаДокументОперация,
| СсылкаНаДокумент.ДатаНачала КАК СсылкаНаДокументДатаНачала,
| СсылкаНаДокумент.Продолжительность КАК СсылкаНаДокументПродолжительность,
| НомерСтроки КАК НомерСтроки,
| СсылкаНаДокумент.Дата2 КАК СсылкаНаДокументДата2
| ) КАК Операции,
| МедицинскаяКарта.ЛистНетрудоспособности КАК ЛистНетрудоспособности
|ИЗ
| Документ.МедицинскаяКарта КАК МедицинскаяКарта";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();


ТабДок.Очистить();


ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

ШапкаГл = Макет.ПолучитьОбласть("ШапкаГл");
ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
Шапка = Макет.ПолучитьОбласть("Шапка");
ШапкаД = Макет.ПолучитьОбласть("ШапкаД");


ШапкаГл.Параметры.Заполнить(Выборка);
ШапкаГл.Параметры.НаименованиеУчреждения = Константы.НаименованиеУчреждения.Получить();

ТабДок.Вывести(ШапкаГл, Выборка.Уровень());
ОбластьЗаголовок.Параметры.Номер = Выборка.Номер;

ТабДок.Вывести(ОбластьЗаголовок);

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

ШапкаД.Параметры.Заполнить(Выборка);
ТабДок.Вывести(ШапкаД, Выборка.Уровень());

ВставлятьРазделительСтраниц = Истина;
КонецЦикла;
//}}
КонецПроцедуры

На скрине выводятся все документы, а мне нужен только один определенный

Afinogen


Afinogen

Цитата: steeld от 25 июн 2023, 21:55Процедура Стационарная(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Стационарная)
Макет = Документы.МедицинскаяКарта.ПолучитьМакет("Стационарная");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| МедицинскаяКарта.Ссылка КАК Ссылка,
| МедицинскаяКарта.ВерсияДанных КАК ВерсияДанных,
| МедицинскаяКарта.ПометкаУдаления КАК ПометкаУдаления,
| МедицинскаяКарта.Номер КАК Номер,
| МедицинскаяКарта.Дата КАК Дата,
| МедицинскаяКарта.Проведен КАК Проведен,
| МедицинскаяКарта.Тип КАК Тип,
| МедицинскаяКарта.ДатаПоступления КАК ДатаПоступления,
| МедицинскаяКарта.ДатаВыписки КАК ДатаВыписки,
| МедицинскаяКарта.Отделение КАК Отделение,
| МедицинскаяКарта.Палата КАК Палата,
| МедицинскаяКарта.ПроведеноВОтделении КАК ПроведеноВОтделении,
| МедицинскаяКарта.ВидТранспортировки КАК ВидТранспортировки,
| МедицинскаяКарта.ГруппаКрови КАК ГруппаКрови,
| МедицинскаяКарта.ПобочноеДействиеЛекарств КАК ПобочноеДействиеЛекарств,
| МедицинскаяКарта.АдресПроживания КАК АдресПроживания,
| МедицинскаяКарта.Пол КАК Пол,
| МедицинскаяКарта.ДатаРождения КАК ДатаРождения,
| МедицинскаяКарта.Возраст КАК Возраст,
| МедицинскаяКарта.СНИЛС КАК СНИЛС,
| МедицинскаяКарта.Пациент КАК Пациент,
| МедицинскаяКарта.НомерПолиса КАК НомерПолиса,
| МедицинскаяКарта.ДиагнозКлинический КАК ДиагнозКлинический,
| МедицинскаяКарта.КодДиагноза КАК КодДиагноза,
| МедицинскаяКарта.ДатаУстановления КАК ДатаУстановления,
| МедицинскаяКарта.Фамилия КАК Фамилия,
| МедицинскаяКарта.Имя КАК Имя,
| МедицинскаяКарта.Отчетство КАК Отчетство,
| МедицинскаяКарта.КемНаправлен КАК КемНаправлен,
| МедицинскаяКарта.ГруппаИнвалидности КАК ГруппаИнвалидности,
| МедицинскаяКарта.Инвалидность КАК Инвалидность,
| МедицинскаяКарта.МестоРаботы КАК МестоРаботы,
| МедицинскаяКарта.Трудоспособность КАК Трудоспособность,
| МедицинскаяКарта.ИсходЗаболевания КАК ИсходЗаболевания,
| МедицинскаяКарта.Учреждение КАК Учреждение,
| МедицинскаяКарта.Пользователь КАК Пользователь,
| МедицинскаяКарта.КодЛьготы КАК КодЛьготы,
| МедицинскаяКарта.Стадия КАК Стадия,
| МедицинскаяКарта.ДатаНачалаДиспНаблюдения КАК ДатаНачалаДиспНаблюдения,
| МедицинскаяКарта.ДатаПрекрДиспНаблюдения КАК ДатаПрекрДиспНаблюдения,
| МедицинскаяКарта.Врач КАК Врач,
| МедицинскаяКарта.Операции.(
| СсылкаНаДокумент.Врач КАК СсылкаНаДокументВрач,
| СсылкаНаДокумент.Терапия КАК СсылкаНаДокументТерапия,
| СсылкаНаДокумент.Операция КАК СсылкаНаДокументОперация,
| СсылкаНаДокумент.ДатаНачала КАК СсылкаНаДокументДатаНачала,
| СсылкаНаДокумент.Продолжительность КАК СсылкаНаДокументПродолжительность,
| НомерСтроки КАК НомерСтроки,
| СсылкаНаДокумент.Дата2 КАК СсылкаНаДокументДата2
| ) КАК Операции,
| МедицинскаяКарта.ЛистНетрудоспособности КАК ЛистНетрудоспособности
|ИЗ
| Документ.МедицинскаяКарта КАК МедицинскаяКарта";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();


ТабДок.Очистить();



На скрине выводятся все документы, а мне нужен только один определенный


добавьте условие

|ГДЕ Документ.Ссылка = &Ссылка

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск