Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 июл 2024, 06:12

Выбор отчетов в зависимости от роли пользователя

Автор acelysX, 21 июн 2023, 10:06

0 Пользователей и 1 гость просматривают эту тему.

acelysX

Как сделать привязку пользователя к определенному отчету, чтобы при выборе пользователя выводились те отчеты, которые доступны ему, а не которые доступны вприницпе?
Процедура ПриОткрытииНаСервере()
СписокОтчетов = Новый СписокЗначений;
Для каждого Отчет Из Метаданные.Отчеты Цикл
ЭлементСписка = СписокОтчетов.Добавить(Отчет);
КонецЦикла;
ВыбранныйЭлемент = СписокОтчетов.ВыбратьЭлемент("Выберите отчет", СписокОтчетов[0]);
Если ВыбранныйЭлемент <> Неопределено Тогда
Отчеты[ВыбранныйЭлемент.Значение.Имя].ПолучитьФорму().Открыть();
КонецЕсли;
КонецПроцедуры
Процедура ВыборПользователя()
ФРМ = Справочники.Пользователи.ПолучитьФормуВыбора();
Результат = ФРМ.ОткрытьМодально();
Если Результат = Неопределено Тогда
Возврат;
КонецЕсли;
КонецПроцедуры

Afinogen

 B) ну для начала те отчеты которые доступны должны быть как то в базе настроены  B)

acelysX

Afinogen, я настроил под роль, все равно выводит весь список

acelysX

Afinogen, поставил доступными для определенной роли 4 отчета, выводиться весь список

Теги: роли отчеты 

Похожие темы (5)

Рейтинг@Mail.ru

Поиск