Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 фев 2024, 15:47

Установка курса валюты при нажатии на кнопку

Автор Dmitrii_VVV, 02 июн 2023, 15:52

0 Пользователей и 1 гость просматривают эту тему.

Dmitrii_VVV

Коллеги, помогите пожалуйста начинающему

Необходимо, при заполнении ТЧ валюта, выбора даты и нажатии на кнопку Валюта 3, вывести в ТЧ курс текущий курс

Пока только ругается, не понимаю что править на клиенте и как процедуру на сервере сформировать


&НаКлиенте
Процедура Валюта3(Команда)
   Если ЗначениеЗаполнено(Элементы.СписокНоменклатуры.ТекущиеДанные) Тогда
       Курс = Валюта2НаСервере(Элементы.СписокНоменклатуры.ТекущиеДанные, Объект.Дата);
      
      Для каждого Запись из Объект.СписокНоменклатуры цикл
      Запись.Валюта = Курс;
      КонецЦикла;
   КонецЕсли;
КонецПроцедуры



&НаСервере
Функция Валюта3НаСервере() 
   
   
КонецФункции
 



https://wampi.ru/image/RVpHakz

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск