Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 мая 2024, 10:39

Печать, добавление реквизита

Автор aboba174, 01 июн 2023, 13:49

0 Пользователей и 1 гость просматривают эту тему.

aboba174

Здравствуйте, у меня есть печать в документе "Оказание услуги", и так как у меня ФИО в разных реквизитах, то соответвенно в печати выводится только фамилия (наименования). Как можно добавить еще имя и отчество?Безымянный.png

aboba174

Вот сюда не знаю как добавить еще имя и отчество
Модуль менеджера:

Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
Макет = Документы.ОказаниеУслуги.ПолучитьМакет("Печать");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ОказаниеУслуги.Дата,
| ОказаниеУслуги.Клиент,
| ОказаниеУслуги.Номер,         
| ОказаниеУслуги.Склад,
| ОказаниеУслуги.Сотрудник,
| ОказаниеУслуги.ПереченьНоменклатуры.(
| НомерСтроки,
| Номенклатура,
| Количество,
| Цена,
| Сумма
| )
|ИЗ
| Документ.ОказаниеУслуги КАК ОказаниеУслуги
|ГДЕ
| ОказаниеУслуги.Ссылка В (&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
Шапка = Макет.ПолучитьОбласть("Шапка");
ОбластьПереченьНоменклатурыШапка = Макет.ПолучитьОбласть("ПереченьНоменклатурыШапка");
ОбластьПереченьНоменклатуры = Макет.ПолучитьОбласть("ПереченьНоменклатуры");
ОбластьИтог = Макет.ПолучитьОбласть("Всего");
ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

ТабДок.Вывести(ОбластьЗаголовок);

Шапка.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Шапка, Выборка.Уровень());

ТабДок.Вывести(ОбластьПереченьНоменклатурыШапка);
ВыборкаПереченьНоменклатуры = Выборка.ПереченьНоменклатуры.Выбрать();
СуммаИтог = 0;
Пока ВыборкаПереченьНоменклатуры.Следующий() Цикл
ОбластьПереченьНоменклатуры.Параметры.Заполнить(ВыборкаПереченьНоменклатуры);
ТабДок.Вывести(ОбластьПереченьНоменклатуры, ВыборкаПереченьНоменклатуры.Уровень());

СуммаИтог = СуммаИтог + ВыборкаПереченьНоменклатуры.Сумма;
КонецЦикла;

ОбластьИтог.Параметры.ВсегоПоДокументу = СуммаИтог;
ТабДок.Вывести(ОбластьИтог);
ВставлятьРазделительСтраниц = Истина;
КонецЦикла;
//}}
КонецПроцедуры

LexaK

aboba174, так очевидно же, просто надо сложить
примерно так
Параметры.Сотрудник = "" + Выборка.Фамилия + " " + Выборка.Имя + " " + Выборка.Отчество;
получится Иванов Иван Иванович

или так
Параметры.Сотрудник = "" + Выборка.Фамилия + " " + Лев(Выборка.Имя,1) + "." + Лев(Выборка.Отчество,1 + ".";
получится Иванов И.И.
если помогло нажмите: Спасибо!

aboba174

LexaK,

Вот такую ошибку дает.
Вставил вот такой код:
Шапка.Параметры.Сотрудник = "" + Выборка.Фамилия + " " + Выборка.Имя + " " + Выборка.Отчество;
Поле объекта не обнаружено (Фамилия)
{Документ.ОказаниеУслуги.МодульМенеджера(33)}:   Шапка.Параметры.Сотрудник = "" + Выборка.Фамилия + " " + Выборка.Имя + " " + Выборка.Отчество;
{Документ.ОказаниеУслуги.Команда.Печать.МодульКоманды(18)}:   Документы.ОказаниеУслуги.Печать(ТабДок, ПараметрКоманды);
{Документ.ОказаниеУслуги.Команда.Печать.МодульКоманды(6)}:   Печать(ТабДок, ПараметрКоманды);[/code]

Как мне к ним можно обратиться

LexaK

aboba174, по идее сюда
        Шапка.Параметры.Заполнить(Выборка);
Шапка.Параметры.Сотрудник = "" + Выборка.Сотрудник + " " + Выборка.Имя + " " + Выборка.Отчество;//СВОИ имена реквизитов подставьте
        ТабДок.Вывести(Шапка, Выборка.Уровень());
если помогло нажмите: Спасибо!

aboba174

LexaK, Все работает, спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск