Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2024, 07:18

помощь с обучением

Автор Ronin58, 30 мая 2023, 13:41

0 Пользователей и 1 гость просматривают эту тему.

Ronin58

Добрый день! Прошу не считать за глупость, еще учусь. Как в реквизит на форме вывести результат запроса при нажатии на кнопку? 

код : 


&НаСервереБезКонтекста
Процедура ОбъеденинениеВзапросНаСервере()
       Запрос = Новый запрос;
   запрос.Текст = "ВЫБРАТЬ
   |   ПриходнаяНакладнаяСостав.Товар,
   |  ПриходнаяНакладнаяСостав.Ссылка.Дата,
   |  ПриходнаяНакладнаяСостав.Ссылка.Поставщик
   |   ПОМЕСТИТЬ  ПоступлениеТоваров
   |    ИЗ
   |         Документ.ПриходнаяНакладная.Состав КАК ПриходнаяНакладнаяСостав
   |         ГДЕ
   |                  МЕСЯЦ (ПриходнаяНакладнаяСостав.Ссылка.Дата) = 11;
   |      /////////////////////////////////////////////////////////////
   |     ВЫБРАТЬ
   |             Товары.Наименование КАК Наименование,
   |             Товары.Производитель,
   |             ПоступлениеТоваров.Дата,
   |             ПоступлениеТоваров.Поставщик
   |        ИЗ
   |         Справочник.Товары КАК Товары
   |       ЛЕВОЕ СОЕДИНЕНИЕ  поступлениеТоваров КАК ПоступлениеТоваров
   |     ПО (ПоступлениеТоваров.Товар = Товары.Ссылка)
   |     УПОРЯДОЧИТЬ ПО
      |    Наименование ИЕРАРХИЯ";

   результатЗапроса = Запрос.Выполнить().выгрузить();   
   
   
                  КонецПроцедуры

&НаКлиенте
Процедура ОбъеденинениеВзапрос(Команда)
   ОбъеденинениеВзапросНаСервере();
КонецПроцедуры




LexaK

Ronin58, добавил код, вывод в табдок (не проверял)
&НаСервере //////БезКонтекста
Процедура ОбъеденинениеВзапросНаСервере()
       Запрос = Новый запрос;
   запрос.Текст = "ВЫБРАТЬ
   |   ПриходнаяНакладнаяСостав.Товар,
   |  ПриходнаяНакладнаяСостав.Ссылка.Дата,
   |  ПриходнаяНакладнаяСостав.Ссылка.Поставщик
   |   ПОМЕСТИТЬ  ПоступлениеТоваров
   |    ИЗ
   |         Документ.ПриходнаяНакладная.Состав КАК ПриходнаяНакладнаяСостав
   |ГДЕ
   | МЕСЯЦ (ПриходнаяНакладнаяСостав.Ссылка.Дата) = 11
   |;
   |/////////////////////////////////////////////////////////////
   |     ВЫБРАТЬ
   |             Товары.Наименование КАК Наименование,
   |             Товары.Производитель,
   |             ПоступлениеТоваров.Дата,
   |             ПоступлениеТоваров.Поставщик
   |        ИЗ
   |         Справочник.Товары КАК Товары
   |       ЛЕВОЕ СОЕДИНЕНИЕ  поступлениеТоваров КАК ПоступлениеТоваров
   |     ПО (ПоступлениеТоваров.Товар = Товары.Ссылка)
   |     УПОРЯДОЧИТЬ ПО
   |    Наименование ИЕРАРХИЯ";

   результатЗапроса = Запрос.Выполнить().выгрузить();   
   
   //заполняем табличный документ
   Результат.Очистить();
   лкПоз = 0;
   Для каждого лкСтр Из результатЗапроса Цикл
    лкПоз = лкПоз + 1;
Результат.Область(лкПоз,1).Текст = лкСтр.Наименование;
Результат.Область(лкПоз,2).Текст = лкСтр.Производитель;
Результат.Область(лкПоз,3).Текст = лкСтр.Дата;
Результат.Область(лкПоз,4).Текст = лкСтр.Поставщик;
   КонецЦикла;
   
КонецПроцедуры
если помогло нажмите: Спасибо!

Теги:

Похожие темы (2)

Рейтинг@Mail.ru

Поиск