Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 июл 2024, 04:39

Подсчет дней в журнале посещаемости

Автор mariasssssss, 28 мая 2023, 17:31

0 Пользователей и 1 гость просматривают эту тему.

mariasssssss

Здравствуйте, подскажите, пожалуйста как можно реализовать подсчет количества дней (где был - пустая клетка, не был - буква н) в журнале посещаемости  :trhregerhg:

LexaK

mariasssssss, это документ с табличной частью?
структуру (описание колонок) покажите
если помогло нажмите: Спасибо!

mariasssssss

LexaK, да, документ с табличной частью
у всех чисел такие свойства, если Вы про это

alexandr_ll

mariasssssss, Примерно так

СекундВСутках = 60 * 60 * 24;

Для Индекс = 1 По 31 Цикл

Дата = НачалоМесяца(Объект.ДатаНачала) + (Индекс - 1) * СекундВСутках;
ДанныеПоДню = ДанныеКалендаря.Получить(Дата);


ЧасовОтработано = 0;

Если ДанныеПоДню <> Неопределено Тогда
Иначе
         <Считаем>
КонецЕсли;
   КонецЦикла;

LexaK

mariasssssss, добавьте на форму кнопку: Подсчет посещений, в обработчик кнопки вызов этой процедуры
Внимание! Правильно подставьте наименования своих реквизитов
&НаКлиенте
Процедура РассчитатьПосещения()

Для каждого лкСтр Из ТабличнаяЧасть Цикл
лкСтр.КоличествоПосещений = 0;
Для лкДень = 1 По 31 Цикл
Попытка
//проверяем день месяца
лкДата = Дата(Объект.Год, Объект.Месяц, лкДень); //Год и Месяц должны быть цифрами
Исключение
//выход за месяц
Прервать;
КонецПопытки;
Если ПустаяСтрока(лкСтр["Число" + лкДень]) Тогда
//считаем дни без отметки
лкСтр.КоличествоПосещений = лкСтр.КоличествоПосещений + 1;
КонецЕсли;
КонецЦикла;
КонецЦикла;

КонецПроцедуры
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск