Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 июл 2024, 06:07

Добавление объектов в ТЧ с условием

Автор Pi, 20 мая 2023, 17:37

0 Пользователей и 1 гость просматривают эту тему.

Pi

Каким образом можно добавить объекты из тч одного документа в тч другого документа при условии?(интересует добавление учеников в тч документа "исключениеизшколы" при условии что у них оценка в текущем документе равна 2)
(Процедура ОбработкаПроведения(Отказ, РежимПроведения)
Для каждого Ученика из СписокУчеников Цикл
КонецЦикла;
Если Ученика.Оценка = 2 Тогда
НовДок = Документы.ИсключениеИзШколы.СоздатьДокумент();
НовДок.Дата = ТекущаяДата();
НовДок.Записать(РежимЗаписиДокумента.Запись);
КонецЕсли;
КонецПроцедуры

Kvark5d

Pi, примерно так, только названия реквизитов и табл. частей изменить
// найдем все двоечников
ПоискДвоечников = СписокУчеников.НайтиСтроки(Новый Структура("Оценка",2)
// если нашли хоть одного, создадим документ ИскоючениеИзшколы
Если ПоискДвоечников.Количество()<>0 Тогда
    НовДок = Документы.ИсключениеИзШколы.СоздатьДокумент();
    НовДок.Дата = ТекущаяДата();
    //добавим данного ученика в табличную часть документа ИсключениеИзШколы
    ТабличнаяЧасть = НовДок.ТабличнаяЧасть; // ТабличнаяЧасть заменить на наименование табличной части документа исключениеизшколы   
    Для Каждого Двоечник ИЗ ПоискДвоечников Цикл
        НовСтр = ТабличнаяЧасть .Добавить();
        НовСтр.Ученик = Двоечник.Ученик;   // Ученик заменить на названия реквизитов
    КонецЦикла;
    НовДок.Записать(РежимЗаписиДокумента.Запись);
КонецЕсли;   

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск