Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 фев 2024, 16:13

нужна помощь

Автор shams, 18 мая 2023, 14:10

0 Пользователей и 1 гость просматривают эту тему.

shams

Здраствуйте хотел бы спросить как сравнить цену чтобы  сделать так чтобы показать пользователю в виде сообщения вида "Самый дешевый товар: Смартфон Samsung Galaxy A12, цена: 352 руб. 55 коп."



&НаКлиенте
Процедура Массивтоваров(Команда)
   

   МассивТоваров = Новый Массив ;
   
   //
   ДанныеRedmi = Новый Структура;
   
   ДанныеRedmi.Вставить("Артикул" , "184601023");
   ДанныеRedmi.Вставить("Наименование" , "Смартфон Xiaomi Redmi 9 3/32GB, зеленый");
   ДанныеRedmi.Вставить("Штрихкод" , "978020137962");
   ДанныеRedmi.Вставить("Цена" , "418.12");
   
   МассивТоваров.Добавить(ДанныеRedmi);
   
   //
   ДанныеGalaxy  = Новый Структура;
   
   ДанныеGalaxy.Вставить("Артикул" , "215543732");
   ДанныеGalaxy.Вставить("Наименование" , "Смартфон Samsung Galaxy A12");
   ДанныеGalaxy.Вставить("Штрихкод" , "478020147962");
   ДанныеGalaxy.Вставить("Цена" , "352.55");
   
   МассивТоваров.Добавить(ДанныеGalaxy);
   //
    Для Каждого ЭлементСтруктуры Из ДанныеGalaxy Цикл
      Сообщить(ЭлементСтруктуры.Ключ + ": " + ЭлементСтруктуры.Значение);
   КонецЦикла;

   
   //
   ДанныеPoco   = Новый Структура;
   
   ДанныеPoco.Вставить("Артикул" , "254514022");
   ДанныеPoco.Вставить("Наименование" , "Смартфон Poco X3 Pro 8");
   ДанныеPoco.Вставить("Штрихкод" , "448021147962");
   ДанныеPoco.Вставить("Цена" , "734.07");
   
   МассивТоваров.Добавить(ДанныеPoco);
   
   //Для Каждого ЭлементСтруктуры Из ДанныеPoco Цикл
   //   Сообщить(ЭлементСтруктуры.Ключ + ": " + ЭлементСтруктуры.Значение);
   //КонецЦикла;

   
   Для Каждого Элемент Из МассивТоваров Цикл
      Если Элемент = МассивТоваров   Тогда
         дешевый   = Элемент;
      КонецЕсли;      
   КонецЦикла;
   
   Сообщить("------");
   Сообщить("Самый дешевый товар: " + ДанныеGalaxy );
   
   
      
КонецПроцедуры

Afinogen

синтаксис помощник

ЧислоПрописью()

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск