Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 июл 2024, 06:13

Получить номенклатуру в цикле

Автор Dmitrii_VVV, 16 мая 2023, 17:02

0 Пользователей и 1 гость просматривают эту тему.

Dmitrii_VVV

Всем доброго!

Сильно начинающий, знания околонулевые

Задача: Назначить процедуру для кнопки, получить номенклатуру в цикле, далее данный код
&НаКлиенте
Процедура Команда1(Команда)
   
   
   
   НаборЗаписей = РегистрыСведений.ЦеныНоменклатуры.СоздатьНаборЗаписей();
    НаборЗаписей.Отбор.Номенклатура.Установить(Номенклатура);
    НаборЗаписей.Прочитать(); 
   
КонецПроцедуры


Подскажите пожалуйста куда копать?

Советы типа гоу на курсы или читай литературу боюсь не помогут

Максим75

Dmitrii_VVV, вот пример из статьи

МенеджерЦеныНаТопливо = РегистрыСведений.ЦеныНаТопливо;
НаборЗаписей = МенеджерЦеныНаТопливо.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.ПоставщикТоплива.Установить(Поставщик);
НаборЗаписей.Прочитать();
Если НаборЗаписей.Количество() <> 0 Тогда
    Для Каждого стрНабора из НаборЗаписей Цикл
        стрНабора.Цена = стрНабора.Цена * Коэффицент;
    КонецЦикла;
    НаборЗаписей.Записать();
КонецЕсли;

заменить на свое и как-то так

Optiman

&НаКлиенте? Что вы там собрались читать? Это на сервере делается

Максим75

Цитата: Optiman от 17 мая 2023, 06:46&НаКлиенте? Что вы там собрались читать? Это на сервере делается
ага, даже и не глянул на это.
ну там просто вызов серверной процедуры сделать и код написать.

Afinogen

Dmitrii_VVV, для начала разобраться что  можно вызывать на сервере что на клиенте

antoneus

Цитата: Afinogen от 17 мая 2023, 09:21Dmitrii_VVV, для начала разобраться что  можно вызывать на сервере что на клиенте

Это литературу читать надо... Не пойдет.

Dmitrii_VVV

Всем спасибо, сижу разбираюсь дальше!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск