Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2024, 05:34

Удалить из строки повторяющиеся символы

Автор shams, 10 мая 2023, 12:19

0 Пользователей и 1 гость просматривают эту тему.

shams

как удалить из строки повторяющиеся символы?


например для строки AAABBBCC ФУНКЦИЯ ДОЛЖНА ВЕРНУТЬ  ABC

antoneus

Повторяющиеся на соседних позициях или вообще должна возвращаться строка уникальных символов?

shams

antoneus, Повторяющиеся на соседних позициях

Kvark5d

shams,
Функция УбратьПовторяющиесяПоследовательноСимволы(Текст)
НоваяСтрока="";
ПровСимвол="";
Для а=1 По СтрДлина(Текст) Цикл
ТекСимвол = Сред(Текст,а,1);
Если ТекСимвол <> ПровСимвол Тогда
НоваяСтрока=НоваяСтрока+ТекСимвол;
ПровСимвол=ТекСимвол;
КонецЕсли;
КонецЦикла;
Возврат НоваяСтрока;
КонецФункции

shams


Kvark5d


shams

Kvark5d, Недостаточно фактических параметров (УбратьПовторяющиесяПоследовательноСимволы)
НоваяСтрока = <<?>>УбратьПовторяющиесяПоследовательноСимволы(); (Проверка: Тонкий клиент)

Kvark5d

shams, система четко пишет - недостаточно параметров. Ну видно же, что в функцию надо передать исходный текст.
Пример:
НоваяСтрока = УбратьПовторяющиесяПоследовательноСимволы(СтрокаКоторуюНужноИзменить)

LexaK

Kvark5d, сейчас напишет,  :lol:
Опять ни чего не работает! Ошибка: Не определена переменная СтрокаКоторуюНужноИзменить!!!  :D
если помогло нажмите: Спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск