Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 июн 2024, 15:17

помогите, в табличной части сравнить текущее значение с предыдущим

Автор lam_anna, 27 апр 2023, 12:25

0 Пользователей и 1 гость просматривают эту тему.

lam_anna

Задача в следующем, создаются документы из эксель. В табличную часть документа необходимо записывать данные у которых один и тот же контрагент. Т.е для одного контрагента создавать один документ, для другого следующий.
Документы создаются, но не одним а несколько. 
Таблицу предварительно отсортировала по столбцу Контрагент

Подскажите, что не так?
Жалуется на Неопознанный оператор

текКонтрагент = 0;
Док = 0;
    Для Каждого Строка Из ТаблицаНовая Цикл
Если текКонтрагент <> (строка.Контрагент) Тогда
Если Док <> 0 Тогда
Попытка
                    Док.Записать(РежимЗаписиДокумента.Проведение);
                Исключение
                    Ошибка = ОписаниеОшибки();
                    Сообщить(Ошибка);
КонецПопытки;
КонецЕсли;
  текКонтрагент <> (строка.Контрагент);

//тут создается новый документ
Док = Документы.ЗаказКлиента.СоздатьДокумент();
.....
КонецЕсли;

//тут добавляется табличная часть
Строка = Док.Товары.Добавить();
.....
КонецЦикла;

Если Док  <> 0 Тогда
Попытка
Док.Записать(РежимЗаписиДокумента.Проведение);
Исключение
Ошибка = ОписаниеОшибки();
            Сообщить(Ошибка);
КонецПопытки;
КонецЕсли;

antoneus

    Попытка
        Док.Записать(РежимЗаписиДокумента.Проведение);
    Исключение
        Ошибка = ОписаниеОшибки();
        Сообщить(Ошибка);
    КонецПопытки;
КонецЕсли;
текКонтрагент = строка.Контрагент;//тут надо =, а не <>

lam_anna


Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск