Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 мая 2024, 09:48

Вывести итог в макет печатной формы из конструктора

Автор Руслан Джанбосынов, 27 апр 2023, 06:08

0 Пользователей и 1 гость просматривают эту тему.

Руслан Джанбосынов

Всем привет!Я начинающий кодер по этому строго не судите. Ситуация следующая:
Создан документ "Акт приема" в конфигурации УТ 3.4.4.91 Редакция для Казахстана.
Вывел итог по весу Нетто в подвал Формы документа все отлично.
Подскажите теперь как вывести его в макет печатной формы накладной созданной на конструкторе?

Макет = Документы.АктПриёма.ПолучитьМакет("Печать");
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   АктПриёма.Дата,
   |   АктПриёма.Итого,
   |   АктПриёма.Комментарий,
   |   АктПриёма.Номер,
   |   АктПриёма.Поставщик,
   |   АктПриёма.Принял,
   |   АктПриёма.Сдал,
   |   АктПриёма.Склад,
   |   АктПриёма.Транспорт,
   |   АктПриёма.Лом.(
   |      НомерСтроки,
   |      Номенклатура,
   |      КоличествоБэгов,
   |      ВесБэга,
   |      МусорИПрочее,
   |      Тара,
   |      Брутто,
   |      Нетто
   |   )
   |ИЗ
   |   Документ.АктПриёма КАК АктПриёма
   |
   |ГДЕ
   |   АктПриёма.Ссылка В (&Ссылка)";
   Запрос.Параметры.Вставить("Ссылка", Ссылка);
   Выборка = Запрос.Выполнить().Выбрать();

   ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
   Шапка = Макет.ПолучитьОбласть("Шапка");
   ОбластьЛомШапка = Макет.ПолучитьОбласть("ЛомШапка");
   ОбластьЛом = Макет.ПолучитьОбласть("Лом");
   Подвал = Макет.ПолучитьОбласть("Подвал");

   ТабДок.Очистить();

   ВставлятьРазделительСтраниц = Ложь;
   Пока Выборка.Следующий() Цикл
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
      КонецЕсли;

      ТабДок.Вывести(ОбластьЗаголовок);

      Шапка.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(Шапка, Выборка.Уровень());

      ТабДок.Вывести(ОбластьЛомШапка);
      ВыборкаЛом = Выборка.Лом.Выбрать();
      Пока ВыборкаЛом.Следующий() Цикл
         ОбластьЛом.Параметры.Заполнить(ВыборкаЛом);
         ТабДок.Вывести(ОбластьЛом, ВыборкаЛом.Уровень());
      КонецЦикла;

      Подвал.Параметры.Заполнить(Выборка);
      ТабДок.Вывести(Подвал);

      ВставлятьРазделительСтраниц = Истина;
   КонецЦикла;
   
КонецПроцедуры

LexaK

по вашему коду все должно выводится!
в документе есть реквизит Итого
он выводится в область Подвала! (проверьте область макета Подвал есть ли там Параметр Итого?)
какой еще Итог вы хотите вывести?
если помогло нажмите: Спасибо!

Руслан Джанбосынов

LexaK, реквизит есть в подвале но выдается пустое значение, нужно рассчитать по весу Нетто общий итог по всем позициям документа.


LexaK

Руслан Джанбосынов,
Цитироватьреквизит есть в подвале
Итого это не Нетто!

Параметр Нетто есть?
если есть попробуйте такой код добавить (строчки с //добавить)
  ТабДок.Вывести(ОбластьЛомШапка);
      ВыборкаЛом = Выборка.Лом.Выбрать();   
  СуммаНетто = 0; //добавить
      Пока ВыборкаЛом.Следующий() Цикл
  СуммаНетто = СуммаНетто + ВыборкаЛом.Нетто; //добавить
         ОбластьЛом.Параметры.Заполнить(ВыборкаЛом);
         ТабДок.Вывести(ОбластьЛом, ВыборкаЛом.Уровень());
      КонецЦикла;

      Подвал.Параметры.Заполнить(Выборка);
      Подвал.Параметры.Нетто = СуммаНетто;//добавить
      ТабДок.Вывести(Подвал);
если помогло нажмите: Спасибо!

Руслан Джанбосынов

LexaK, вааааааах ваааах что за тигр этот Лев)))как часики работает все теперь Низкий Вам поклон! :ooifh:  :ooifh:  :ooifh:

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск