Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 июл 2024, 05:45

ошибка кода

Автор shams, 24 апр 2023, 09:48

0 Пользователей и 1 гость просматривают эту тему.

shams

   "ВЫБРАТЬ
    |    ПользователиКонтактнаяИнформация.АдресЭП КАК АдресЭП
    |ИЗ
    |    Справочник.Пользователи.КонтактнаяИнформация КАК ПользователиКонтактнаяИнформация
    |ГДЕ
    |    ПользователиКонтактнаяИнформация.Ссылка = &Ссылка
    |    И ПользователиКонтактнаяИнформация.АдресЭП <> """"";
   
    Запрос.УстановитьПараметр("Ссылка", ПараметрыСеанса.ТекущийПользователь());
   
    Выборка = Запрос.Выполнить().Выбрать();
    Если Выборка.Следующий() Тогда
        Почта = Выборка.АдресЭП
    КонецЕсли;

здраствуйте сделал условия для того чтобы получить данные пользователя код ошибка дает кто не будь может может помочь

shams

{ВнешняяОбработка.ВнешняяОбработка.МодульОбъекта(1,5)}: Неопознанный оператор
    <<?>>"ВЫБРАТЬ (Проверка: Сервер)



вот такая ошибка дает

antoneus

А вначале есть ли там такие важные слова:

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|    ПользователиКонтактнаяИнформация.АдресЭП КАК АдресЭП
.......

?


shams

antoneus, да  вот так выглядит
   Запрос = Новый Запрос;
   запрос.Текст =
     "ВЫБРАТЬ
    |    ПользователиКонтактнаяИнформация.АдресЭП КАК АдресЭП
    |ИЗ
    |    Справочник.Пользователи.КонтактнаяИнформация КАК ПользователиКонтактнаяИнформация
    |ГДЕ
    |    ПользователиКонтактнаяИнформация.Ссылка = &Ссылка
    |    И ПользователиКонтактнаяИнформация.АдресЭП <> """"";
   
    Запрос.УстановитьПараметр("Ссылка", ПараметрыСеанса.ТекущийПользователь());
   
    Выборка = Запрос.Выполнить().Выбрать();
    Если Выборка.Следующий() Тогда
        Почта = Выборка.АдресЭП
   КонецЕсли;
   

shams

antoneus, а его надо на внешней обработке проверить ?

shams

antoneus, и его на сервере надо пробовать ?

shams

antoneus, так тоже пробовал ничего не показывает

&НаСервере
Процедура ПоказатьНаСервере()
   
   Запрос = Новый Запрос;
   запрос.Текст =
     "ВЫБРАТЬ
    |    ПользователиКонтактнаяИнформация.АдресЭП КАК АдресЭП
    |ИЗ
    |    Справочник.Пользователи.КонтактнаяИнформация КАК ПользователиКонтактнаяИнформация
    |ГДЕ
    |    ПользователиКонтактнаяИнформация.Ссылка = &Ссылка
    |    И ПользователиКонтактнаяИнформация.АдресЭП <> """"";
   
    Запрос.УстановитьПараметр("Ссылка", ПараметрыСеанса.ТекущийПользователь());
   
    Выборка = Запрос.Выполнить().Выбрать();
    Если Выборка.Следующий() Тогда
        Почта = Выборка.АдресЭП
   КонецЕсли;
   
КонецПроцедуры

&НаКлиенте
Процедура Показать(Команда)
   ПоказатьНаСервере()
КонецПроцедуры
   

Волшебник

Кому на сервере Вы хотите показывать? Там только друзья-упсы и товарищи-маршрутизаторы.

antoneus

А что должен показывать? Код выполняет присвоение адреса эп, если таковой найдется, переменной Почта. Чтобы что-нибудь "показало", надо у 1с вежливо об этом попросить. Например

Если Выборка.Следующий() Тогда
    Почта = Выборка.АдресЭП;
    Сообщить(Почта)
КонецЕсли;

shams

Волшебник,некому это тестовая база хотел так пробовать ошибка не дает но результат 0

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск