Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июн 2024, 06:54

АктСписанияМЗ вывод даты в печатной форме

Автор Vasylii, 19 апр 2023, 12:54

0 Пользователей и 1 гость просматривают эту тему.

Vasylii

не могу понять почему дата не выводится, прикрепил скрин с областью и самим параметром, пытался прописывать через параметры и тд не выходит, отладка не работает сижу уже битый час и ничего
Пока ВыборкаМатериалы.Следующий() Цикл

ОбластьМакетаСтрока.Параметры.Заполнить(ВыборкаМатериалы);

СтруктураПараметров = Новый Структура("Цена, Сумма, СчетДебета, СчетКредита");
СтруктураОтбора = Новый Структура("НомерСтрокиДокумента", ВыборкаМатериалы.НомерСтроки);

ТекущиеДвижения = ТаблицаДвижений.НайтиСтроки(СтруктураОтбора);
Если ТекущиеДвижения.Количество() > 0 Тогда
ТекущееДвижение = ТекущиеДвижения[0];

Если ТекущееДвижение.Количество <> 0 Тогда
Цена = Окр(ТекущееДвижение.Сумма / ТекущееДвижение.Количество, 2);
Иначе
Цена = 0;
КонецЕсли;
Сумма = ТекущееДвижение.Сумма;

Если ЗначениеЗаполнено(ТекущееДвижение.СчетДт) Тогда
СтруктураПараметров.СчетДебета = УправлениеПечатьюБГУ.ПредставлениеРабочегоСчета(
ТекущееДвижение.КПСДт, ТекущееДвижение.КФО, ТекущееДвижение.СчетДт, ТекущееДвижение.КЭКДт,,)
КонецЕсли;
СтруктураПараметров.СчетКредита = УправлениеПечатьюБГУ.ПредставлениеРабочегоСчета(
ТекущееДвижение.КПСКт, ТекущееДвижение.КФО, ТекущееДвижение.СчетКт, ТекущееДвижение.КЭККт,,);
Иначе
Цена = 0;
Сумма = 0;
КонецЕсли;

СтруктураПараметров.Цена = Формат(Цена, "ЧДЦ=2");
СтруктураПараметров.Сумма = Формат(Сумма, "ЧДЦ=2");
ОбластьМакетаСтрока.Параметры.Заполнить(СтруктураПараметров);

Если ВыборкаМатериалы.НомерСтроки <> КоличествоСтрок Тогда
Если Не ТабДокумент.ПроверитьВывод(ОбластьМакетаСтрока) Тогда
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
ТабДокумент.Вывести(ОбластьМакетаШапка);
#Вставка
ОбластьМакетаДата.Параметры.Дата = ВыборкаДокументы.ТекстДата;
#КонецВставки
КонецЕсли;
Иначе
Области = Новый Массив;
Области.Добавить(ОбластьМакетаСтрока);
Области.Добавить(ОбластьМакетаИтого);
Области.Добавить(ОбластьМакетаПодвал);
Области.Добавить(ОбластьЗаключение);
Области.Добавить(ОбластьКомиссия);
Области.Добавить(ОбластьМакетаДата);
Если Не ТабДокумент.ПроверитьВывод(Области) Тогда
ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
ТабДокумент.Вывести(ОбластьМакетаШапка);
КонецЕсли;
КонецЕсли;

СуммаИтого = СуммаИтого + Сумма;
КоличествоИтого = КоличествоИтого + ВыборкаМатериалы.Количество;

ТабДокумент.Вывести(ОбластьМакетаСтрока);

КонецЦикла;

СтруктураПараметров = Новый Структура;
СтруктураПараметров.Вставить("КоличествоИтого", КоличествоИтого);
СтруктураПараметров.Вставить("СуммаИтого", Формат(СуммаИтого, "ЧДЦ=2"));
СтруктураПараметров.Вставить("СуммаИтогоПрописью",
ОбщегоНазначенияБГУ.СформироватьСуммуПрописью(СуммаИтого, Неопределено));
ОбластьМакетаИтого.Параметры.Заполнить(СтруктураПараметров);
ТабДокумент.Вывести(ОбластьМакетаИтого);
ОбластьМакетаПодвал.Параметры.Заполнить(СтруктураПараметров);
ТабДокумент.Вывести(ОбластьМакетаПодвал);
ТабДокумент.Вывести(ОбластьЗаключение);
ТабДокумент.Вывести(ОбластьКомиссия);
ТабДокумент.Вывести(ОбластьМакетаДата);

// В табличном документе зададим имя области, в которую был
// выведен объект. Нужно для возможности печати покомплектно.
УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабДокумент,
НомерСтрокиНачало, ОбъектыПечати, ВыборкаДокументы.Ссылка);

Для каждого ТекДвижение Из СтрокиДвижений Цикл

ДвиженияДокументов.Удалить(ТекДвижение);

КонецЦикла;

КонецЦикла;

Возврат ТабДокумент;

Kvark5d

Vasylii, как минимум надо вынести строку:
ОбластьМакетаДата.Параметры.Дата = ВыборкаДокументы.ТекстДата;
из всех Если

Vasylii


Похожие темы (5)

Рейтинг@Mail.ru

Поиск