Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 фев 2024, 09:17

Значение не является значением объектного типа (Найти)

Автор KUU, 19 апр 2023, 08:54

0 Пользователей и 1 гость просматривают эту тему.

KUU

В общий модуль из процедуры печать в общий модуль не передается значение, я не понимаю, из-за чего.В других обработках такой же код работает.
Прошу ткнуть носом в ошибку.




Функция СведенияОВнешнейОбработке() Экспорт


ПараметрыРегистрации = Новый Структура;
МассивНазначений = Новый Массив;
МассивНазначений.Добавить("Документ.ПриемНаРаботу"); //Указываем документ к которому делаем внешнюю печ. форму 

ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма");
ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
ПараметрыРегистрации.Вставить("Наименование", "СрочныйТД"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
ПараметрыРегистрации.Вставить("Версия", "1.0");
ПараметрыРегистрации.Вставить("Информация", "СрочныйТД");
ТаблицаКоманд = ПолучитьТаблицуКоманд();
ДобавитьКоманду(ТаблицаКоманд, "СрочныйТД", "СрочныйТД", "ВызовСерверногоМетода", Истина, "ПечатьMXL");
ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

Возврат ПараметрыРегистрации;

КонецФункции



Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт


Если ТипЗнч(МассивОбъектов[0]) = Тип("ДокументСсылка.ПриемНаРаботу") Тогда
УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "СрочныйТД", "СрочныйТД",
        СформироватьСрочныйТД(МассивОбъектов[0], ОбъектыПечати));  //*
КонецЕсли;

Конецпроцедуры

KUU


Afinogen


KUU


KUU

KUU, мне помогли сформулировать проблему конкретнее, В коллекции печатных форм не может найтись имя макета

KUU

Я поменяла код в процедуре печать, теперь вот так:

Если Управлениепечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "СрочныйТД") тогда

  УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияпечатныхФорм, "СрочныйТД", "Срочный ТД",
      СформироватьСрочныйТД(МассивОбъектов[0], ОбъектыПечати,"СрочныйТД"));///, Неопределено,Неопределено);           
КонецЕсли;

Afinogen


Afinogen

KUU,
у вас название темы "Значение не является значением объектного типа" - эта ошибка возникает когда передается переменная некорректного типа

KUU


KUU

Afinogen, передается оно нормально, проблема в том, что значения нет в коллекции печатных форм

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск