Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 мая 2024, 09:49

Переключение тумблера в 1с предприятие

Автор mariasssssss, 13 апр 2023, 15:01

0 Пользователей и 1 гость просматривают эту тему.

mariasssssss

Здравствуйте, попыталась создать тумблер ПроживаетПоМестуРегистрации, после нажатия которого текст из поля МестоРегистрации передавался бы в поле МестоПроживания, выходит ошибка - Поле объекта не обнаружено (ЭлементыФормы)
{Справочник.Специалисты.Форма.ФормаЭлемента.Форма(4)}:ТекущийЭлемент = Элемент.ЭлементыФормы.Получить("ПроживаетПоМестуРегистрации");

[ОшибкаВоВремяВыполненияВстроенногоЯзыка, ОшибкаИспользованияВстроенногоЯзыка]

Вот мой код:

&НаКлиенте
Процедура ПроживаетПоМестуРегистрацииПриИзменении(Элемент)
  ТекущийЭлемент = Элемент.ЭлементыФормы.Получить("ПроживаетПоМестуРегистрации");
  Значение = ТекущийЭлемент.Значение;
 
  ОбъектСотрудника = Элемент.ТекущиеДанные;
  Если Значение = Истина Тогда
    ОбъектСотрудника.МестоПроживания = ОбъектСотрудника.МестоРегистрации;
  Иначе
    ОбъектСотрудника.МестоПроживания = "";
  КонецЕсли;
 
КонецПроцедуры

antoneus

&НаКлиенте
Процедура ПроживаетПоМестуРегистрацииПриИзменении(Элемент)
  Если ПроживаетПоМестуРегистрации Тогда
    Объект.МестоПроживания = Объект.МестоРегистрации;
  Иначе
    Объект.МестоПроживания = "";
  КонецЕсли;
 
КонецПроцедуры

mariasssssss

antoneus, здравствуйте,
&НаКлиенте
Процедура ПроживаетПоМестуРегистрацииПриИзменении(Элемент)
Перем ПроживаетПоМестуРегистрации;
Перем ОбъектСотрудника;
  Если ПроживаетПоМестуРегистрации = Истина Тогда
    ОбъектСотрудника.МестоПроживания = ОбъектСотрудника.МестоРегистрации;
  Иначе
    ОбъектСотрудника.МестоПроживания = "";
  КонецЕсли;
КонецПроцедуры

я объявила переменные, потому что была ошибка, потом была ошибка, что не может быть выполнено преобразование к типу булево и я добавила = истина, теперь ошибка значение не является значением объектного типа (МестоПроживания), не понимаю как ее исправить

antoneus


mariasssssss

antoneus, появляется ошибка, когда я вставляю Ваш код

antoneus

Вот эти слова что означают?

Цитата: mariasssssss от 13 апр 2023, 15:01попыталась создать тумблер ПроживаетПоМестуРегистрации

К событию какого элемента формы привязана процедура ПроживаетПоМестуРегистрацииПриИзменении?

mariasssssss

antoneus, я хотела, чтобы при нажатии на тумблере ПроживаетПоМестуРегистрации истина, данные из поля МестоРегистрации передавались в поле МестоПроживания, ниже скрин

antoneus

Это реквизит формы или справочника?

antoneus

Попробуйте так

&НаКлиенте
Процедура ПроживаетПоМестуРегистрацииПриИзменении(Элемент)
  Если Объект.ПроживаетПоМестуРегистрации Тогда
    Объект.МестоПроживания = Объект.МестоРегистрации;
  Иначе
    Объект.МестоПроживания = "";
  КонецЕсли;
 
КонецПроцедуры

mariasssssss


Похожие темы (5)

Рейтинг@Mail.ru

Поиск