Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 июн 2024, 16:49

ВыделениеСтрок в ТЧ

Автор Vasylii, 04 апр 2023, 13:40

0 Пользователей и 1 гость просматривают эту тему.

Vasylii

Не могу понять почему выделяется только первые две строчки а не все у кого поле ошибка истина
Для каждого тек Из объект.Табличная Цикл
Элементы.Табличная.ВыделенныеСтроки.Добавить(тек.Ошибка);
КонецЦикла;


Kvark5d

Для каждого тек Из объект.Табличная Цикл
   Если тек.Ошибка Тогда     
           Элементы.Табличная.ВыделенныеСтроки.Добавить(тек.ПолучитьИдентификатор());
   КонецЕсли;
КонецЦикла;



Vasylii

Kvark5d, а почему получить индетификатор?

Kvark5d

Vasylii, я не силен в управляемых формах. В разных местах в инете пишут, что там должно быть ли НомерСтроки либо ее идентификатор. И вроде как идентификатор правильнее

Vasylii

Kvark5d, понял спасибо большое

Рейтинг@Mail.ru

Поиск