Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 мар 2024, 04:41

Рассчёт скидки покупателю, прошу помощи.

Автор SoulPower, 04 июн 2011, 10:38

0 Пользователей и 1 гость просматривают эту тему.

SoulPower

Задача: Добавить автоматически расчёт скидки покупателю при оформлении расходной накладной, Размер скидки зависит от суммы уже произведённых закупок в предыдущем месяце.

Скидки я храню в справочнике, сделки покупателей в регистре Продажи. Из клиентского приложения при изминении клиента вызываю функцию, которая выполняется на сервере, вот листинг:

Функция ВычислениеСкидки(Клиент) Экспорт
   ДатаНачала = НачалоМесяца(ДобавитьМесяц(ТекущаяДата(), -1));
   ДатаОкончания = КонецМесяца(ДобавитьМесяц(ТекущаяДата(), -1));
   ОборотКлиента = РегистрыНакопления.Продажи.Обороты(ДатаНачала,ДатаОкончания,,Клиент,"Выручка");
    Запрос = Новый Запрос;
   Запрос.Текст ="ВЫБРАТЬ
                 |   Скидки.ОбъемЗакупки КАК ОбъемЗакупки,
                 |   Скидки.ПроцентСкидки
                 |ИЗ
                 |   Справочник.Скидки КАК Скидки
                 |
                 |УПОРЯДОЧИТЬ ПО
                 |   ОбъемЗакупки УБЫВ";
   Результат = Запрос.Выполнить();
   ТЗ = Результат.Выгрузить();
   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Если ОборотКлиента >= ВыборкаДетальныеЗаписи.ОбъемЗакупки тогда
         Возврат ВыборкаДетальныеЗаписи.ПроцентСкидки;
      КонецЕсли;
   КонецЦикла;   
КонецФункции

Проблема вот в чём:
Метод Обороты() ругается на параметр Клиент, а я ему вроде передаю строку как и надо.

Да и вообще нихрена не работает, помогите плиз)

   

Теги:
Рейтинг@Mail.ru

Поиск